pcapsipdump libc++ fix
authorJohn Crispin <john@openwrt.org>
Sat, 4 Aug 2012 17:02:13 +0000 (17:02 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 4 Aug 2012 17:02:13 +0000 (17:02 +0000)
SVN-Revision: 32983

net/pcapsipdump/Makefile

index 03fa71f3552fc95c98bc83aa2f286061f0e3f308..ad077469548124941ff932e492293753efb9b796 100644 (file)
@@ -9,19 +9,20 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcapsipdump
 PKG_VERSION:=0.1.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/psipdump
 PKG_MD5SUM:=95ed26caf66237a654cae2cacdaa3386
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcapsipdump
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Telephony
-  DEPENDS:=+libpcap +uclibcxx
+  DEPENDS:=+libpcap $(CXX_DEPENDS)
   TITLE:=SIP sessions dumping tool
   URL:=http://sourceforge.net/projects/pcapsipdump/
 endef
@@ -32,12 +33,13 @@ define Package/pcapsipdump/description
         (even if there is thousands of concurrect SIP sessions).
 endef
 
+TARGET_CC=$(TARGET_CXX)
+
 define Build/Compile
        $(TARGET_CONFIGURE_OPTS) \
                $(MAKE) -C $(PKG_BUILD_DIR) \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++"  \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               LIBS="-lpcap -luClibc++"
+               CPPFLAGS="$(TARGET_CXXFLAGS) -fno-rtti"  \
+               LIBS="-lpcap"
 endef
 
 define Package/pcapsipdump/install