tools/pkgconf: update to 1.7.3
authorRosen Penev <rosenp@gmail.com>
Thu, 17 Dec 2020 07:33:55 +0000 (23:33 -0800)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Dec 2020 17:59:10 +0000 (18:59 +0100)
Remove upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/pkgconf/Makefile
tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch [deleted file]

index cefee1edf06f1fa652911b8b72c0738d86b5d179..7d785aae3937c25ca3294eac77d299b9d167176d 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkgconf
-PKG_VERSION:=1.6.3
+PKG_VERSION:=1.7.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf
-PKG_HASH:=61f0b31b0d5ea0e862b454a80c170f57bad47879c0c42bd8de89200ff62ea210
+PKG_HASH:=b846aea51cf696c3392a0ae58bef93e2e72f8e7073ca6ad1ed8b01c85871f9c0
 
 HOST_BUILD_PARALLEL:=1
 
diff --git a/tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch b/tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch
deleted file mode 100644 (file)
index b2c538d..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 62bbd3b664d4b03011a4b382ed20353a91c30406 Mon Sep 17 00:00:00 2001
-From: Ariadne Conill <ariadne@dereferenced.org>
-Date: Tue, 21 Jan 2020 10:32:36 -0600
-Subject: [PATCH] cli: remove --version to --modversion remapping
-
-This has been a source of frequent complaints, so we drop it.
-Resolves: https://todo.sr.ht/~kaniini/pkgconf/6
----
- cli/main.c | 14 ++------------
- 1 file changed, 2 insertions(+), 12 deletions(-)
-
-diff --git a/cli/main.c b/cli/main.c
-index 563ec8f0cfcd..fc698a4f9191 100644
---- a/cli/main.c
-+++ b/cli/main.c
-@@ -1005,18 +1005,8 @@ main(int argc, char *argv[])
-       if ((want_flags & PKG_VERSION) == PKG_VERSION)
-       {
--              if (argc > 2)
--              {
--                      fprintf(stderr, "%s: --version specified with other options or module names, assuming --modversion.\n", argv[0]);
--
--                      want_flags &= ~PKG_VERSION;
--                      want_flags |= PKG_MODVERSION;
--              }
--              else
--              {
--                      version();
--                      return EXIT_SUCCESS;
--              }
-+              version();
-+              return EXIT_SUCCESS;
-       }
-       if ((want_flags & PKG_HELP) == PKG_HELP)