Revert "procps-ng: update to 4.0.4"
authorkrant <aleksey.vasilenko@gmail.com>
Thu, 1 Feb 2024 15:34:58 +0000 (17:34 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Fri, 16 Feb 2024 12:47:52 +0000 (13:47 +0100)
The props-ng packages adds a new API version that breaks other
downstream packages. This revert is a preparation commit to move the old
API to procps-ng3 so that the new API could use procps-ng packages
name again.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
This reverts commit 81629ba5918f48a0886e6f601d63d0b016ef8c1e.

utils/procps-ng/Makefile
utils/procps-ng/patches/100-no-tests-docs.patch

index 2ded481039f554360a450fbecddf56e1c80b12c7..0fad39b9d73898b9ce58ad77f4ebc36f2203e7a5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procps-ng
-PKG_VERSION:=4.0.4
-PKG_RELEASE:=1
+PKG_VERSION:=3.3.16
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/procps-ng
-PKG_HASH:=22870d6feb2478adb617ce4f09a787addaf2d260c5a8aa7b17d889a962c5e42e
+PKG_HASH:=925eacd65dedcf9c98eb94e8978bbfb63f5de37294cc1047d81462ed477a20af
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=GPL-2.0-or-later
@@ -94,7 +94,7 @@ MAKE_FLAGS += \
 
 define Package/procps-ng/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libproc2.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprocps.so* $(1)/usr/lib/
 endef
 
 define Build/InstallDev
index d9dd2292ebd66ec873ffa096d91f7ff90687f4d7..b863fba3de4bfefcaa1cdb56e4940d1cf068abef 100644 (file)
@@ -1,26 +1,26 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -18,10 +18,7 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
+@@ -14,10 +14,7 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
  
  ACLOCAL_AMFLAGS = -I m4
  SUBDIRS = \
--      local \
--      po-man \
+-      include \
+-      man-po \
 -      po \
 -      testsuite
-+      local
++      include
  
- AM_CFLAGS = -Ilibrary/include
- LDADD = ./library/libproc2.la $(CYGWINFLAGS)
+ AM_CFLAGS = -Iproc
+ LDADD = ./proc/libprocps.la $(CYGWINFLAGS)
 --- a/configure.ac
 +++ b/configure.ac
-@@ -421,8 +421,5 @@ AC_CHECK_FUNCS([__fpending alarm atexit
+@@ -298,8 +298,5 @@ AC_CHECK_FUNCS([__fpending alarm atexit
  
  AC_CONFIG_FILES([Makefile
-                  local/Makefile
--                 po-man/Makefile
+                  include/Makefile
+-                 man-po/Makefile
 -                 po/Makefile.in
--                 library/libproc2.pc
+-                 proc/libprocps.pc
 -                 testsuite/Makefile])
-+                 library/libproc2.pc])
++                 proc/libprocps.pc])
  AC_OUTPUT