ddns-scripts: fix handling of passwords with slashes (#12160)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 10 Sep 2012 10:03:39 +0000 (10:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 10 Sep 2012 10:03:39 +0000 (10:03 +0000)
SVN-Revision: 33358

net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_updater.sh

index 5a99d8d08185950b8774541a6c869f9b480c85e8..651c623592868d4dbe84bff25c1c28df5c7d6abb 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=20
+PKG_RELEASE:=21
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 0c5718b04655ffd37e568b462d36ada6c0d15f96..580bed84fcbb0a904da3446f65bdc2ee76fbbc6f 100755 (executable)
@@ -305,7 +305,7 @@ do
                                final_url=$(echo $final_url | sed s^"$replace_name"^"$replace_value"^g )
                        fi
                done
-               final_url=$(echo $final_url | sed s/"\[HTTPAUTH\]"/"$username${password:+:$password}"/g )
+               final_url=$(echo $final_url | sed s^"\[HTTPAUTH\]"^"${username//^/\\^}${password:+:${password//^/\\^}}"^g )
                final_url=$(echo $final_url | sed s/"\[IP\]"/"$current_ip"/g )