tagya: do not add the old network proto scripts if netifd is enabled, add a TODO...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 14 May 2012 23:35:46 +0000 (23:35 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 14 May 2012 23:35:46 +0000 (23:35 +0000)
SVN-Revision: 31731

ipv6/tayga/Makefile

index c109a923fe3b5e9d515c4934f1653e5e8069bfcf..5d043ae38161ea3abd4e57c7b398ac2ccb5256b4 100644 (file)
@@ -29,11 +29,19 @@ define Package/tayga/description
   kernel, which is the same driver used by OpenVPN and QEMU/KVM.
 endef
 
-define Package/tayga/install
+# TODO: port scripts to netifd
+ifdef CONFIG_PACAKGE_netifd
+  define Package/tayga/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tayga $(1)/usr/sbin/
+  endef
+else
+  define Package/tayga/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/lib/network $(1)/etc/hotplug.d/iface
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tayga $(1)/usr/sbin/
        $(INSTALL_DATA) ./files/tayga.sh $(1)/lib/network/tayga.sh
        $(INSTALL_DATA) ./files/tayga.hotplug $(1)/etc/hotplug.d/iface/95-tayga
-endef
+  endef
+endif
 
 $(eval $(call BuildPackage,tayga))