ipq806x: onhub: Enable fstools_partname_fallback_scan
authorBrian Norris <computersforpeace@gmail.com>
Wed, 25 Jan 2023 06:42:07 +0000 (22:42 -0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 4 Feb 2023 19:16:20 +0000 (20:16 +0100)
When fstools is unable to parse our root=<...> arg correctly, it can
fall back to scanning all block devices for a 'rootfs_data' partition.
This fallback was deemed wrong (or at least, a breaking/incompatible
change) for some targets, so we're forced to opt back into it with
fstools_partname_fallback_scan=1.

Without this, OnHub devices will use a rootfs-appended loop device for
rootfs_data instead of the intended 3rd partition.

While I'm at it, just move all the boot args into the 'cros-vboot'
build rule, instead of using the custom bootargs-append. All cros-vboot
subtargets here are using the same rootwait (to support both eMMC and
USB boot) and root/partition args.

Signed-off-by: Brian Norris <computersforpeace@gmail.com>
[ drop unrelated comments in commit description ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/ipq806x/files-5.15/arch/arm/boot/dts/qcom-ipq8064-asus-onhub.dts
target/linux/ipq806x/files-5.15/arch/arm/boot/dts/qcom-ipq8064-tplink-onhub.dts
target/linux/ipq806x/image/chromium.mk

index 5b60ddb04b3f8dbcfcaf86a19c9041ba6eefde72..442bcf19a675b18b7995c880829b4276c7cee4e1 100644 (file)
 / {
        model = "ASUS OnHub";
        compatible = "asus,onhub", "google,arkham", "qcom,ipq8064";
-
-       chosen {
-               bootargs-append = " rootwait";
-       };
 };
 
 &qcom_pinmux {
index 6dd39f0d95842c63df26656499cd8a7341d05260..6adc6be4aec61b64870852c2336cf73b31d06716 100644 (file)
 / {
        model = "TP-Link OnHub";
        compatible = "tplink,onhub", "google,whirlwind-sp5", "qcom,ipq8064";
-
-       chosen {
-               bootargs-append = " rootwait";
-       };
 };
 
 &qcom_pinmux {
index 16af6b95ba6c81fea86894366e4b696b4c556ab4..f908472419d1ce24c86cf2e3f14e18e5bf8cb6c0 100644 (file)
@@ -20,7 +20,9 @@ endef
 # (PARTNROFF=1) partition as their rootfs.
 define Build/cros-vboot
        $(STAGING_DIR_HOST)/bin/cros-vbutil \
-               -k $@ -c "root=PARTUUID=%U/PARTNROFF=1" -o $@.new
+               -k $@ \
+               -c "root=PARTUUID=%U/PARTNROFF=1 rootwait fstools_partname_fallback_scan=1" \
+               -o $@.new
        @mv $@.new $@
 endef