tor-alpha: update to 0.2.3.15-alpha, re-enable fixed UPnP support
authorStephen Walker <stephendwalker@gmail.com>
Thu, 3 May 2012 22:19:35 +0000 (22:19 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Thu, 3 May 2012 22:19:35 +0000 (22:19 +0000)
SVN-Revision: 31579

net/tor-alpha/Makefile
net/tor-alpha/patches/001-torrc.patch

index f298b7b3afb9ba16838a195d82ba9524c3f46fa4..05a661441df0e586bd462321a11278d97fed92a4 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-alpha
-PKG_VERSION:=0.2.3.13-alpha
+PKG_VERSION:=0.2.3.15-alpha
 PKG_RELEASE:=1
 
 PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.torproject.org/dist \
        https://archive.torproject.org/tor-package-archive
-PKG_MD5SUM:=503d7b043875e9745db7cb06a26e2c5c
+PKG_MD5SUM:=80c6019b6cfa5106282e46ae81c9b59c
 
-PKG_BUILD_DEPENDS:=libnatpmp
+PKG_BUILD_DEPENDS:=libminiupnpc libnatpmp
 PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)
 PKG_INSTALL:=1
 
@@ -50,7 +50,7 @@ endef
 define Package/tor-alpha-fw-helper
 $(call Package/tor-alpha/Default)
   TITLE:=Firewall helper for tor
-  DEPENDS:=+tor-alpha +libnatpmp
+  DEPENDS:=+tor-alpha +libminiupnpc +libnatpmp
 endef
 
 define Package/tor-alpha-fw-helper/description
@@ -76,6 +76,8 @@ endef
 CONFIGURE_ARGS += \
        --with-libevent-dir="$(STAGING_DIR)/usr" \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
+       --enable-upnp \
+       --with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
        --enable-nat-pmp \
        --with-libnatpmp-dir="$(STAGING_DIR)/usr" \
        --enable-bufferevents \
index 8c9e03192587786e3533306e7322a89637970232..988cb8e5a0d964eaabd89ae51e6773341da9c3de 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/config/torrc.sample.in
 +++ b/src/config/torrc.sample.in
-@@ -46,11 +46,11 @@ SocksListenAddress 127.0.0.1 # accept co
+@@ -45,11 +45,11 @@
  ## Uncomment this to start the process in the background... or use
  ## --runasdaemon 1 on the command line. This is ignored on Windows;
  ## see the FAQ entry if you want Tor to run as an NT service.
@@ -14,7 +14,7 @@
  
  ## The port on which Tor will listen for local connections from Tor
  ## controller applications, as documented in control-spec.txt.
-@@ -182,3 +182,4 @@ SocksListenAddress 127.0.0.1 # accept co
+@@ -187,3 +187,4 @@
  ## address manually to your friends, uncomment this line:
  #PublishServerDescriptor 0