kernel: bump 4.14 to 4.14.274
authorPetr Štetiar <ynezz@true.cz>
Mon, 28 Mar 2022 09:39:18 +0000 (11:39 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 28 Mar 2022 09:39:18 +0000 (11:39 +0200)
All patches refreshed automagically without conflicts.

Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch

index 73bbcbb04e032143f611854530948855c52dd266..d0ac3b2ee1e64fe8c933d53f0763265745b0ce19 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .273
+LINUX_VERSION-4.14 = .274
 
-LINUX_KERNEL_HASH-4.14.273 = 1bfd1b320a7167cf6cf0a8a1e9f7f1e5932b997c9041507c5aaff80b8dacbc2d
+LINUX_KERNEL_HASH-4.14.274 = 2b42538fcb88df5113e1797ab18252ac6ba876f1d13c83af6ea7c6430b0f7fad
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 1bb30ab6ca5980f8039a90949e15ec8a8c0a4a78..82afb03d29c9f28ffb8438d04ef4e0cfb75ba03c 100644 (file)
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
        rwlock_t                sk_callback_lock;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2791,6 +2791,7 @@ void sock_init_data(struct socket *sock,
+@@ -2788,6 +2788,7 @@ void sock_init_data(struct socket *sock,
  
        sk->sk_max_pacing_rate = ~0U;
        sk->sk_pacing_rate = ~0U;
index e6b761d3c00ec6e47bd0fe40ef49e219d639b642..a517b6fa6a820827243e12ad4ebfb9eb108c074b 100644 (file)
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3430,6 +3430,8 @@ static __net_initdata struct pernet_oper
+@@ -3427,6 +3427,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {