bind: update to 9.9.0
authorStephen Walker <stephendwalker@gmail.com>
Fri, 2 Mar 2012 05:22:12 +0000 (05:22 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 2 Mar 2012 05:22:12 +0000 (05:22 +0000)
SVN-Revision: 30771

net/bind/Makefile
net/bind/patches/001-no-tests.patch [new file with mode: 0644]

index 5f9e6e35acb6dd271b48e66c5df4c007ca825cf4..d6aaadc23bcf8b4bd3cf1a53d4b499ea7a9c2b86 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.8.1-P1
-PKG_RELEASE:=2
+PKG_VERSION:=9.9.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=afa41f8203d50bedad65071f9b6f96d7
+PKG_MD5SUM:=9281d0b04f711d28153ba1ab04a54026
 
 PKG_FIXUP:=libtool
 
@@ -89,7 +89,8 @@ CONFIGURE_ARGS += \
        --with-libxml2=no \
        --enable-epoll=yes \
        --with-gost=no \
-       --with-gssapi=no
+       --with-gssapi=no \
+       --with-readline=no
 
 CONFIGURE_VARS += \
        BUILD_CC="$(TARGET_CC)" \
diff --git a/net/bind/patches/001-no-tests.patch b/net/bind/patches/001-no-tests.patch
new file mode 100644 (file)
index 0000000..c4dc533
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/bin/Makefile.in
++++ b/bin/Makefile.in
+@@ -19,7 +19,7 @@ srcdir =     @srcdir@
+ VPATH =               @srcdir@
+ top_srcdir =  @top_srcdir@
+-SUBDIRS =     named rndc dig dnssec tests tools nsupdate \
++SUBDIRS =     named rndc dig dnssec tools nsupdate \
+               check confgen @PKCS11_TOOLS@
+ TARGETS =
+--- a/lib/Makefile.in
++++ b/lib/Makefile.in
+@@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
+ # Attempt to disable parallel processing.
+ .NOTPARALLEL:
+ .NO_PARALLEL:
+-SUBDIRS =     isc isccc dns isccfg bind9 lwres tests
++SUBDIRS =     isc isccc dns isccfg bind9 lwres
+ TARGETS =
+ @BIND9_MAKE_RULES@