mvebu: cortexa9: disable devices using broken mv88e6176 switch
authorPetr Štetiar <ynezz@true.cz>
Thu, 1 Dec 2022 09:36:01 +0000 (10:36 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 5 Dec 2022 14:16:19 +0000 (15:16 +0100)
Several users have reported, that devices using mv88e6176 switch are
seriously broken, basically turning that switch into a hub. Until fixed
those devices should be disabled.

I've used TOH with "Switch 88E6176" filter, which provided me with the
following list of likely affected devices:

 * Linksys WRT1200AC v1/v2, WRT1900AC v1/v2
 * SolidRun ClearFog Pro
 * Turris Omnia

That device list more or less corresponds with the list of devices
mentioned in the linked bug reports.

References: https://github.com/openwrt/openwrt/issues/11077
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/mvebu/image/cortexa9.mk

index d9738903fb0413113984bd43c7eae4768ed3a51e..ac83e62e8a5c6ffe3916a0f79e94ecf1bee6b5f6 100644 (file)
@@ -66,6 +66,7 @@ define Device/cznic_turris-omnia
   DEVICE_IMG_NAME = $$(2)
   SUPPORTED_DEVICES += armada-385-turris-omnia
   BOOT_SCRIPT := turris-omnia
+  DEFAULT := n
 endef
 TARGET_DEVICES += cznic_turris-omnia
 
@@ -114,6 +115,7 @@ define Device/linksys
   IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
        append-ubi | pad-to $$$$(PAGESIZE)
   KERNEL_SIZE := 6144k
+  DEFAULT := n
 endef
 
 define Device/linksys_wrt1200ac
@@ -194,6 +196,7 @@ define Device/linksys_wrt32x
   KERNEL_SIZE := 6144k
   KERNEL := kernel-bin | append-dtb
   SUPPORTED_DEVICES += armada-385-linksys-venom linksys,venom
+  DEFAULT := y
 endef
 TARGET_DEVICES += linksys_wrt32x
 
@@ -299,5 +302,6 @@ define Device/solidrun_clearfog-pro-a1
   UBOOT := clearfog-u-boot-spl.kwb
   BOOT_SCRIPT := clearfog
   SUPPORTED_DEVICES += armada-388-clearfog armada-388-clearfog-pro
+  DEFAULT := n
 endef
 TARGET_DEVICES += solidrun_clearfog-pro-a1