dahdi-tools: remove broken patch, disable unused 599/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Thu, 31 Dec 2020 11:20:04 +0000 (12:20 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Thu, 31 Dec 2020 15:17:28 +0000 (16:17 +0100)
The patch "010-fix-non-glibc-builds.patch" is broken. The test for
HAVE_EXECINFO_H must happen after including "<autoconfig.h>".

Instead of fixing the patch this commit removes it. In lieu,
CONFIGURES_ARGS are added to the Makefile. These disable the building of
some tools that are not packaged anyway. Like this, "xpp/xtalk/debug.c"
is avoided, hence the patch becomes irrelevant.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/dahdi-tools/Makefile
libs/dahdi-tools/patches/010-fix-non-glibc-builds.patch [deleted file]

index 32aaba056c9b2c9eccd29ce2dd77f64c1295327e..81aad4eb86f022de6bafd73b913564ef9cc0684f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dahdi-tools
 PKG_VERSION:=3.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/dahdi-tools/releases
@@ -52,7 +52,16 @@ define Package/dahdi-tools-libtonezone
   TITLE:=DAHDI tonezone library
 endef
 
-CONFIGURE_ARGS+=--disable-silent-rules
+CONFIGURE_ARGS += \
+       --disable-silent-rules \
+       --with-perllib="" \
+       --without-libusb \
+       --without-libusbx \
+       --without-newt \
+       --without-pcap \
+       --without-ppp \
+       --without-selinux \
+       --without-usb
 
 # https://issues.asterisk.org/jira/browse/DAHTOOL-85
 TARGET_CFLAGS+=-fcommon
diff --git a/libs/dahdi-tools/patches/010-fix-non-glibc-builds.patch b/libs/dahdi-tools/patches/010-fix-non-glibc-builds.patch
deleted file mode 100644 (file)
index 2aaf145..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/xpp/xtalk/debug.c
-+++ b/xpp/xtalk/debug.c
-@@ -26,7 +26,9 @@
- #include <stdlib.h>
- #include <stdarg.h>
- #include <syslog.h>
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
- #include <xtalk/debug.h>
- #include <autoconfig.h>
-@@ -61,6 +63,7 @@ void dump_packet(int loglevel, int mask,
- /* from glibc info(1) */
- void print_backtrace(FILE *fp)
- {
-+#ifdef HAVE_EXECINFO_H
-       void    *array[10];
-       size_t  size;
-       char    **strings;
-@@ -71,4 +74,5 @@ void print_backtrace(FILE *fp)
-       for (i = 0; i < size; i++)
-               fprintf(fp, "%s\n", strings[i]);
-       free(strings);
-+#endif
- }
---- a/configure.ac
-+++ b/configure.ac
-@@ -161,6 +161,7 @@ AC_SUBST(DAHDI_DECLARATION_AFTER_STATEME
- # Checks for header files.
- AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h])
- AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netinet/in.h stdint.h stdlib.h string.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h])
-+AC_CHECK_HEADERS([execinfo.h])
- # Checks for typedefs, structures, and compiler characteristics.
- AC_C_INLINE