kernel: modules: video: fix kmod-imx-pxp build for 6.1
authorLech Perczak <lech.perczak@gmail.com>
Thu, 11 Jan 2024 21:45:05 +0000 (22:45 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 2 Feb 2024 16:31:44 +0000 (17:31 +0100)
Location of the module file was changed between 5.15 and 6.1. Adapt the
recipe for that.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
package/kernel/linux/modules/video.mk

index 10da2ad3aa0dffa30de0d5d8ece5ba9baff20a21..7ff4a041aea12a7d94a80d6bcb72b731bb7e87c6 100644 (file)
@@ -1165,7 +1165,8 @@ define KernelPackage/video-pxp
   TITLE:=i.MX PXP support
   DEPENDS:=@TARGET_imx +kmod-video-mem2mem +kmod-video-dma
   KCONFIG:= CONFIG_VIDEO_IMX_PXP
-  FILES:= $(LINUX_DIR)/drivers/media/$(V4L2_MEM2MEM_DIR)/imx-pxp.ko
+  FILES:= $(LINUX_DIR)/drivers/media/$(V4L2_MEM2MEM_DIR)/imx-pxp.ko@lt6.1 \
+       $(LINUX_DIR)/drivers/media/platform/nxp/imx-pxp.ko@ge6.1
   AUTOLOAD:=$(call AutoProbe,imx-pxp)
   $(call AddDepends/video)
 endef