ramips: rename include file to a more suitable name
authorMieczyslaw Nalewaj <namiltd@yahoo.com>
Sat, 27 Apr 2024 05:41:51 +0000 (07:41 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 9 May 2024 20:21:39 +0000 (22:21 +0200)
Rename from mt7621_dlink_dir-xx60-a1.dtsi to mt7621_dlink_dir_nand_128m.dtsi
and associated group name when creating the mt7621.mk image

Co-authored-by: Alan Luck <luckyhome2008@gmail.com>
Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
target/linux/ramips/dts/mt7621_dlink_dir-1960-a1.dts
target/linux/ramips/dts/mt7621_dlink_dir-2640-a1.dts
target/linux/ramips/dts/mt7621_dlink_dir-2660-a1.dts
target/linux/ramips/dts/mt7621_dlink_dir-3040-a1.dts
target/linux/ramips/dts/mt7621_dlink_dir-xx60-a1.dtsi [deleted file]
target/linux/ramips/dts/mt7621_dlink_dir_nand_128m.dtsi [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 13883f9f74041cbb34611cac2ce595a2fab04507..531076216deb1212e378523b86d5c319be806cb2 100644 (file)
@@ -2,7 +2,7 @@
 
 #include <dt-bindings/leds/common.h>
 
-#include "mt7621_dlink_dir-xx60-a1.dtsi"
+#include "mt7621_dlink_dir_nand_128m.dtsi"
 
 / {
        compatible = "dlink,dir-1960-a1", "mediatek,mt7621-soc";
index d4b8069a33308944a9056eeec3dd2c4a0ca22342..fd25b94e8dc19f94f9274a0989895c6672d7432b 100644 (file)
@@ -1,6 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "mt7621_dlink_dir-xx60-a1.dtsi"
+#include "mt7621_dlink_dir_nand_128m.dtsi"
 
 / {
        compatible = "dlink,dir-2640-a1", "mediatek,mt7621-soc";
index a4590cb35fc5a7187c3648d396b27c9e00430dd0..d8c347198b5a18e67b1d1c27431d5d6eda0b33f4 100644 (file)
@@ -1,6 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "mt7621_dlink_dir-xx60-a1.dtsi"
+#include "mt7621_dlink_dir_nand_128m.dtsi"
 
 / {
        compatible = "dlink,dir-2660-a1", "mediatek,mt7621-soc";
index 4bb35a948d09e3cbdd9b82f3e5077e2c9b550f8d..0bcfa022fa93dafa80af3a3d2c621a7eeabceb6d 100644 (file)
@@ -1,6 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "mt7621_dlink_dir-xx60-a1.dtsi"
+#include "mt7621_dlink_dir_nand_128m.dtsi"
 
 / {
        compatible = "dlink,dir-3040-a1", "mediatek,mt7621-soc";
diff --git a/target/linux/ramips/dts/mt7621_dlink_dir-xx60-a1.dtsi b/target/linux/ramips/dts/mt7621_dlink_dir-xx60-a1.dtsi
deleted file mode 100644 (file)
index d5adb87..0000000
+++ /dev/null
@@ -1,224 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/leds/common.h>
-
-/ {
-       aliases {
-               label-mac-device = &gmac0;
-               led-boot = &led_power_orange;
-               led-failsafe = &led_power_white;
-               led-running = &led_power_white;
-               led-upgrade = &led_net_orange;
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               wps: wps {
-                       label = "wps";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       leds: leds {
-               compatible = "gpio-leds";
-
-               led_power_orange: power_orange {
-                       function = LED_FUNCTION_POWER;
-                       color = <LED_COLOR_ID_ORANGE>;
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-               };
-
-               led_power_white: power_white {
-                       function = LED_FUNCTION_POWER;
-                       color = <LED_COLOR_ID_WHITE>;
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-               };
-
-               led_net_orange: net_orange {
-                       label = "orange:net";
-                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
-               };
-
-               net_white {
-                       label = "white:net";
-                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&nand {
-       status = "okay";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "Bootloader";
-                       reg = <0x0 0x80000>;
-                       read-only;
-               };
-
-               partition@80000 {
-                       label = "config";
-                       reg = <0x80000 0x80000>;
-                       read-only;
-               };
-
-               partition@100000 {
-                       label = "factory";
-                       reg = <0x100000 0x40000>;
-                       read-only;
-
-                       nvmem-layout {
-                               compatible = "fixed-layout";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               eeprom_factory_0: eeprom@0 {
-                                       reg = <0x0 0x4da8>;
-                               };
-
-                               eeprom_factory_8000: eeprom@8000 {
-                                       reg = <0x8000 0x4da8>;
-                               };
-
-                               macaddr_factory_e000: macaddr@e000 {
-                                       compatible = "mac-base";
-                                       reg = <0xe000 0x6>;
-                                       #nvmem-cell-cells = <1>;
-                               };
-                       };
-               };
-
-               partition@140000 {
-                       label = "config2";
-                       reg = <0x140000 0x40000>;
-                       read-only;
-               };
-
-               partition@180000 {
-                       label = "firmware";
-                       compatible = "openwrt,uimage", "denx,uimage";
-                       openwrt,padding = <96>;
-                       reg = <0x180000 0x2800000>;
-               };
-
-               partition@2980000 {
-                       label = "private";
-                       reg = <0x2980000 0x2000000>;
-                       read-only;
-               };
-
-               partition@4980000 {
-                       label = "firmware2";
-                       reg = <0x4980000 0x2800000>;
-               };
-
-               partition@7180000 {
-                       label = "mydlink";
-                       reg = <0x7180000 0x600000>;
-                       read-only;
-               };
-
-               partition@7780000 {
-                       label = "reserved";
-                       reg = <0x7780000 0x880000>;
-                       read-only;
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi0: wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               nvmem-cells = <&eeprom_factory_0>, <&macaddr_factory_e000 1>;
-               nvmem-cell-names = "eeprom", "mac-address";
-               ieee80211-freq-limit = <2400000 2500000>;
-
-               led {
-                       led-active-low;
-               };
-       };
-};
-
-&pcie1 {
-       wifi1: wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               nvmem-cells = <&eeprom_factory_8000>, <&macaddr_factory_e000 2>;
-               nvmem-cell-names = "eeprom", "mac-address";
-               ieee80211-freq-limit = <5000000 6000000>;
-
-               led {
-                       led-active-low;
-               };
-       };
-};
-
-&gmac0 {
-       nvmem-cells = <&macaddr_factory_e000 0>;
-       nvmem-cell-names = "mac-address";
-};
-
-&gmac1 {
-       status = "okay";
-       label = "wan";
-       phy-handle = <&ethphy4>;
-
-       nvmem-cells = <&macaddr_factory_e000 3>;
-       nvmem-cell-names = "mac-address";
-};
-
-&ethphy4 {
-       /delete-property/ interrupts;
-};
-
-&switch0 {
-       ports {
-               port@0 {
-                       status = "okay";
-                       label = "lan4";
-               };
-
-               port@1 {
-                       status = "okay";
-                       label = "lan3";
-               };
-
-               port@2 {
-                       status = "okay";
-                       label = "lan2";
-               };
-
-               port@3 {
-                       status = "okay";
-                       label = "lan1";
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "i2c", "uart3", "jtag", "wdt";
-               function = "gpio";
-       };
-};
diff --git a/target/linux/ramips/dts/mt7621_dlink_dir_nand_128m.dtsi b/target/linux/ramips/dts/mt7621_dlink_dir_nand_128m.dtsi
new file mode 100644 (file)
index 0000000..d5adb87
--- /dev/null
@@ -0,0 +1,224 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       aliases {
+               label-mac-device = &gmac0;
+               led-boot = &led_power_orange;
+               led-failsafe = &led_power_white;
+               led-running = &led_power_white;
+               led-upgrade = &led_net_orange;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps: wps {
+                       label = "wps";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       leds: leds {
+               compatible = "gpio-leds";
+
+               led_power_orange: power_orange {
+                       function = LED_FUNCTION_POWER;
+                       color = <LED_COLOR_ID_ORANGE>;
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power_white: power_white {
+                       function = LED_FUNCTION_POWER;
+                       color = <LED_COLOR_ID_WHITE>;
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               led_net_orange: net_orange {
+                       label = "orange:net";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               net_white {
+                       label = "white:net";
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "Bootloader";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "config";
+                       reg = <0x80000 0x80000>;
+                       read-only;
+               };
+
+               partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x40000>;
+                       read-only;
+
+                       nvmem-layout {
+                               compatible = "fixed-layout";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               eeprom_factory_0: eeprom@0 {
+                                       reg = <0x0 0x4da8>;
+                               };
+
+                               eeprom_factory_8000: eeprom@8000 {
+                                       reg = <0x8000 0x4da8>;
+                               };
+
+                               macaddr_factory_e000: macaddr@e000 {
+                                       compatible = "mac-base";
+                                       reg = <0xe000 0x6>;
+                                       #nvmem-cell-cells = <1>;
+                               };
+                       };
+               };
+
+               partition@140000 {
+                       label = "config2";
+                       reg = <0x140000 0x40000>;
+                       read-only;
+               };
+
+               partition@180000 {
+                       label = "firmware";
+                       compatible = "openwrt,uimage", "denx,uimage";
+                       openwrt,padding = <96>;
+                       reg = <0x180000 0x2800000>;
+               };
+
+               partition@2980000 {
+                       label = "private";
+                       reg = <0x2980000 0x2000000>;
+                       read-only;
+               };
+
+               partition@4980000 {
+                       label = "firmware2";
+                       reg = <0x4980000 0x2800000>;
+               };
+
+               partition@7180000 {
+                       label = "mydlink";
+                       reg = <0x7180000 0x600000>;
+                       read-only;
+               };
+
+               partition@7780000 {
+                       label = "reserved";
+                       reg = <0x7780000 0x880000>;
+                       read-only;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi0: wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               nvmem-cells = <&eeprom_factory_0>, <&macaddr_factory_e000 1>;
+               nvmem-cell-names = "eeprom", "mac-address";
+               ieee80211-freq-limit = <2400000 2500000>;
+
+               led {
+                       led-active-low;
+               };
+       };
+};
+
+&pcie1 {
+       wifi1: wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               nvmem-cells = <&eeprom_factory_8000>, <&macaddr_factory_e000 2>;
+               nvmem-cell-names = "eeprom", "mac-address";
+               ieee80211-freq-limit = <5000000 6000000>;
+
+               led {
+                       led-active-low;
+               };
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_factory_e000 0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+       status = "okay";
+       label = "wan";
+       phy-handle = <&ethphy4>;
+
+       nvmem-cells = <&macaddr_factory_e000 3>;
+       nvmem-cell-names = "mac-address";
+};
+
+&ethphy4 {
+       /delete-property/ interrupts;
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "lan4";
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan3";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan1";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "uart3", "jtag", "wdt";
+               function = "gpio";
+       };
+};
index 10e78576140f10f3090018b77b589ed25d81a40e..dbb69e0faea1c849a66c820a5a645787ec3272c2 100644 (file)
@@ -742,7 +742,7 @@ define Device/dlink_dir-8xx-r1
        check-size | append-metadata
 endef
 
-define Device/dlink_dir-xx60-a1
+define Device/dlink_dir_nand_128m
   $(Device/nand)
   IMAGE_SIZE := 40960k
   DEVICE_VENDOR := D-Link
@@ -763,35 +763,35 @@ endef
 TARGET_DEVICES += dlink_dir-1935-a1
 
 define Device/dlink_dir-1960-a1
-  $(Device/dlink_dir-xx60-a1)
+  $(Device/dlink_dir_nand_128m)
   DEVICE_MODEL := DIR-1960
   DEVICE_VARIANT := A1
 endef
 TARGET_DEVICES += dlink_dir-1960-a1
 
 define Device/dlink_dir-2640-a1
-  $(Device/dlink_dir-xx60-a1)
+  $(Device/dlink_dir_nand_128m)
   DEVICE_MODEL := DIR-2640
   DEVICE_VARIANT := A1
 endef
 TARGET_DEVICES += dlink_dir-2640-a1
 
 define Device/dlink_dir-2660-a1
-  $(Device/dlink_dir-xx60-a1)
+  $(Device/dlink_dir_nand_128m)
   DEVICE_MODEL := DIR-2660
   DEVICE_VARIANT := A1
 endef
 TARGET_DEVICES += dlink_dir-2660-a1
 
 define Device/dlink_dir-3040-a1
-  $(Device/dlink_dir-xx60-a1)
+  $(Device/dlink_dir_nand_128m)
   DEVICE_MODEL := DIR-3040
   DEVICE_VARIANT := A1
 endef
 TARGET_DEVICES += dlink_dir-3040-a1
 
 define Device/dlink_dir-3060-a1
-  $(Device/dlink_dir-xx60-a1)
+  $(Device/dlink_dir_nand_128m)
   DEVICE_MODEL := DIR-3060
   DEVICE_VARIANT := A1
 endef
@@ -806,7 +806,7 @@ endef
 TARGET_DEVICES += dlink_dir-853-a1
 
 define Device/dlink_dir-853-a3
-  $(Device/dlink_dir-xx60-a1)
+  $(Device/dlink_dir_nand_128m)
   DEVICE_MODEL := DIR-853
   DEVICE_VARIANT := A3
   IMAGES += factory.bin