inotify-tools: fix link error on x86 23549/head
authorkrant <aleksey.vasilenko@gmail.com>
Wed, 28 Feb 2024 11:50:10 +0000 (13:50 +0200)
committerkrant <aleksey.vasilenko@gmail.com>
Wed, 28 Feb 2024 11:50:10 +0000 (13:50 +0200)
Previous commit removed unnecessary linking with libstdc++
but introduced another error on x86 platforms:

  undefined reference to `__stack_chk_fail_local'

Fix it by explicitly linking libssp_nonshared.a

Signed-off-by: krant <aleksey.vasilenko@gmail.com>
utils/inotify-tools/Makefile

index 6d537a828f79b0ac0d0793451e0d187328f80d16..1a81c5e0b67335e550ebcc57089db7a6309cf7a7 100644 (file)
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=inotify-tools
 PKG_VERSION:=4.23.9.0
 PKG_HASH:=1dfa33f80b6797ce2f6c01f454fd486d30be4dca1b0c5c2ea9ba3c30a5c39855
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=https://codeload.github.com/rvoicilas/inotify-tools/tar.gz/$(PKG_VERSION)?
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -25,6 +25,7 @@ endif
 
 ## Avoid linking with libstdcpp
 TARGET_CXXFLAGS+= -nodefaultlibs -lc -fno-exceptions
+TARGET_LDFLAGS+= $(if $(CONFIG_USE_MUSL),-lssp_nonshared)
 
 define Build/Prepare
        $(call Build/Prepare/Default)