kernel: bump 5.4 to 5.4.192
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 10 May 2022 18:34:09 +0000 (18:34 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 17 May 2022 22:11:17 +0000 (00:11 +0200)
Compile-tested: armvirt/64
Run-tested: armvirt/64

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-5.4/950-0208-bcmgenet-Better-coalescing-parameter-defaults.patch
target/linux/bcm27xx/patches-5.4/950-0219-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
target/linux/bcm27xx/patches-5.4/950-0292-net-bcmgenet-Workaround-2-for-Pi4-Ethernet-fail.patch
target/linux/bcm27xx/patches-5.4/950-0336-drm-v3d-The-third-IRQ-is-optional.patch
target/linux/bcm27xx/patches-5.4/950-0973-net-bcmgenet-Reset-RBUF-on-first-open.patch
target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/layerscape/patches-5.4/820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch
target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch

index f92717f957ec78e8666aa5c72d85e77f55fefc05..aaef19eaefee83d0769ec7fffc77b2bd8d4b4eff 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .191
+LINUX_VERSION-5.4 = .192
 
-LINUX_KERNEL_HASH-5.4.191 = 288ca85fcdad18e950ccbe3d640594ee36d5aac226321ed935076fadb0cc0a3a
+LINUX_KERNEL_HASH-5.4.192 = 32482e1152fb07b126180a374f5f7d14601bd13a50ab8cbb75465aa998da9e93
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 8680ececf24a028288463793595a2b25e500697a..d7279170f359262e109134ee0dd3475e77c997f0 100644 (file)
        list_for_each_entry(p, head, list) {
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -460,48 +460,53 @@ static void tcp_options_write(__be32 *pt
+@@ -461,48 +461,53 @@ static void tcp_options_write(__be32 *pt
        u16 options = opts->options;    /* mungable copy */
  
        if (unlikely(OPTION_MD5 & options)) {
        }
  
        if (unlikely(opts->num_sack_blocks)) {
-@@ -509,16 +514,17 @@ static void tcp_options_write(__be32 *pt
+@@ -510,16 +515,17 @@ static void tcp_options_write(__be32 *pt
                        tp->duplicate_sack : tp->selective_acks;
                int this_sack;
  
                }
  
                tp->rx_opt.dsack = 0;
-@@ -531,13 +537,14 @@ static void tcp_options_write(__be32 *pt
+@@ -532,13 +538,14 @@ static void tcp_options_write(__be32 *pt
  
                if (foc->exp) {
                        len = TCPOLEN_EXP_FASTOPEN_BASE + foc->len;
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3976,14 +3976,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3977,14 +3977,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index baaed038558256834885731d23888e8e8cdfdc4c..a52331dff937776b1c044542d83cc6a765290603 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -2150,7 +2150,7 @@ static void bcmgenet_init_tx_ring(struct
+@@ -2157,7 +2157,7 @@ static void bcmgenet_init_tx_ring(struct
  
        bcmgenet_tdma_ring_writel(priv, index, 0, TDMA_PROD_INDEX);
        bcmgenet_tdma_ring_writel(priv, index, 0, TDMA_CONS_INDEX);
@@ -27,7 +27,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Disable rate control for now */
        bcmgenet_tdma_ring_writel(priv, index, flow_period_val,
                                  TDMA_FLOW_PERIOD);
-@@ -3576,9 +3576,12 @@ static int bcmgenet_probe(struct platfor
+@@ -3583,9 +3583,12 @@ static int bcmgenet_probe(struct platfor
        netif_set_real_num_rx_queues(priv->dev, priv->hw_params->rx_queues + 1);
  
        /* Set default coalescing parameters */
index ea99a9ae0b8da16091d2635680168b1588800f6b..3aafe1eb5fc7220aa2a23281f8b80bc829c1f537 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1472,6 +1472,103 @@ command_cleanup:
+@@ -1483,6 +1483,103 @@ command_cleanup:
  }
  
  /*
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -5373,6 +5470,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5384,6 +5481,7 @@ static const struct hc_driver xhci_hc_dr
        .endpoint_reset =       xhci_endpoint_reset,
        .check_bandwidth =      xhci_check_bandwidth,
        .reset_bandwidth =      xhci_reset_bandwidth,
index 321cdb548c125ed56d89d53096092c92395a581d..ebbc07e86d186007ac280b96e6948ba9eea5a788 100644 (file)
@@ -38,7 +38,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  static inline void bcmgenet_writel(u32 value, void __iomem *offset)
  {
        /* MIPS chips strapped for BE will automagically configure the
-@@ -1996,6 +2000,11 @@ static void reset_umac(struct bcmgenet_p
+@@ -2003,6 +2007,11 @@ static void reset_umac(struct bcmgenet_p
        bcmgenet_rbuf_ctrl_set(priv, 0);
        udelay(10);
  
index 2f9eb20addb867f54c1740682ace623fd201512c..50fc594e1e7bd3334ce60f32c9c279646fd17cf5 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -3475,7 +3475,7 @@ static int bcmgenet_probe(struct platfor
+@@ -3482,7 +3482,7 @@ static int bcmgenet_probe(struct platfor
        priv = netdev_priv(dev);
        priv->irq0 = platform_get_irq(pdev, 0);
        priv->irq1 = platform_get_irq(pdev, 1);
index 6d513ee8c168507ba2040bb85b3b318f82d9469c..367eb9ef8d0cfc02d1b80f8d6418e29ebc7d1242 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -2791,7 +2791,7 @@ static void bcmgenet_set_hw_addr(struct
+@@ -2798,7 +2798,7 @@ static void bcmgenet_set_hw_addr(struct
  }
  
  /* Returns a reusable dma control register value */
@@ -33,7 +33,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
  {
        unsigned int i;
        u32 reg;
-@@ -2816,6 +2816,14 @@ static u32 bcmgenet_dma_disable(struct b
+@@ -2823,6 +2823,14 @@ static u32 bcmgenet_dma_disable(struct b
        udelay(10);
        bcmgenet_umac_writel(priv, 0, UMAC_TX_FLUSH);
  
@@ -48,7 +48,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
        return dma_ctrl;
  }
  
-@@ -2911,8 +2919,8 @@ static int bcmgenet_open(struct net_devi
+@@ -2918,8 +2926,8 @@ static int bcmgenet_open(struct net_devi
  
        bcmgenet_set_hw_addr(priv, dev->dev_addr);
  
@@ -59,7 +59,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
  
        /* Reinitialize TDMA and RDMA and SW housekeeping */
        ret = bcmgenet_init_dma(priv);
-@@ -3667,7 +3675,7 @@ static int bcmgenet_resume(struct device
+@@ -3674,7 +3682,7 @@ static int bcmgenet_resume(struct device
                bcmgenet_power_up(priv, GENET_POWER_WOL_MAGIC);
  
        /* Disable RX/TX DMA and flush TX queues */
index 37fee125d71b970552d8b730e5c1b53ebb921b0d..cd6c0f66f6836d55a1c5f21000804d1566bdafae 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
         * All 3.1 IP version constants are greater than the 3.0 IP
 --- a/drivers/usb/dwc3/gadget.c
 +++ b/drivers/usb/dwc3/gadget.c
-@@ -3670,6 +3670,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3699,6 +3699,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
        dwc->gadget.sg_supported        = true;
        dwc->gadget.name                = "dwc3-gadget";
        dwc->gadget.lpm_capable         = true;
index 91156d178c9455a53d33adb1cda00ed9075876d3..c1ddb8cec0cabfbc9f7550f250d4aa9a1375e545 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
                        retval = xhci_enter_test_mode(xhci, test_mode, wIndex,
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -3636,6 +3636,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
+@@ -3638,6 +3638,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
        return 0;
  }
  
@@ -174,7 +174,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
   * bursts that are required to move all packets in this TD.  Only SuperSpeed
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -5401,6 +5401,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5412,6 +5412,7 @@ static const struct hc_driver xhci_hc_dr
        .disable_usb3_lpm_timeout =     xhci_disable_usb3_lpm_timeout,
        .find_raw_port_number = xhci_find_raw_port_number,
        .clear_tt_buffer_complete = xhci_clear_tt_buffer_complete,
index b0a347da1eb9761b04e5c7b5039c0c3e425c804b..128f21b26312d83f448614f8efe27862a688c01e 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -5422,6 +5422,8 @@ void xhci_init_driver(struct hc_driver *
+@@ -5433,6 +5433,8 @@ void xhci_init_driver(struct hc_driver *
                        drv->check_bandwidth = over->check_bandwidth;
                if (over->reset_bandwidth)
                        drv->reset_bandwidth = over->reset_bandwidth;
index ee5a52ea3cfe6c4ade8ea01a304741d5dc645b16..3505231f6b63c4356461b32115b0398f2d406f8c 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct ethtool_eee *p = &priv->dev->ports[port].eee;
 --- a/drivers/net/dsa/lantiq_gswip.c
 +++ b/drivers/net/dsa/lantiq_gswip.c
-@@ -1664,7 +1664,9 @@ static void gswip_phylink_mac_link_down(
+@@ -1661,7 +1661,9 @@ static void gswip_phylink_mac_link_down(
  static void gswip_phylink_mac_link_up(struct dsa_switch *ds, int port,
                                      unsigned int mode,
                                      phy_interface_t interface,