add missing patch for ip175c support
authorFelix Fietkau <nbd@openwrt.org>
Mon, 24 Aug 2009 21:29:38 +0000 (21:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 24 Aug 2009 21:29:38 +0000 (21:29 +0000)
SVN-Revision: 17385

target/linux/generic-2.6/patches-2.6.26/660-ip175c_support.patch [new file with mode: 0644]

diff --git a/target/linux/generic-2.6/patches-2.6.26/660-ip175c_support.patch b/target/linux/generic-2.6/patches-2.6.26/660-ip175c_support.patch
new file mode 100644 (file)
index 0000000..e36d8af
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -82,6 +82,10 @@ config MVSWITCH_PHY
+       ---help---
+         Currently supports the Marvell 88E6060 switch.
++config IP175C_PHY
++      tristate "Driver for IC+ IP175C/IP178C switches"
++      select SWCONFIG
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
++obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o