backport InstallDev/UninstallDev API change to 7.09
authorFelix Fietkau <nbd@openwrt.org>
Sun, 23 Dec 2007 00:43:28 +0000 (00:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 23 Dec 2007 00:43:28 +0000 (00:43 +0000)
SVN-Revision: 9857

include/package.mk

index 2e258a3101a0ebde294307b07e2085bccc0dbd52..8842ac739ba844e7cc77e58b256468a708c1e5e2 100644 (file)
@@ -68,7 +68,7 @@ define Build/DefaultTargets
     compile: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
     $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(STAMP_BUILT)
        mkdir -p $(STAGING_DIR)/stampfiles
-       $(call Build/InstallDev,$(STAGING_DIR))
+       $(call Build/InstallDev,$(STAGING_DIR),$(STAGING_DIR))
        touch $$@
   endif
 
@@ -136,7 +136,7 @@ configure: $(STAMP_CONFIGURED)
 compile:
 install:
 clean: FORCE
-       $(Build/UninstallDev)
+       $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR))
        $(Build/Clean)
        @rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
        @rm -rf $(PKG_BUILD_DIR)