ntpd: trivial fix for eglibc builds
authorFlorian Fainelli <florian@openwrt.org>
Wed, 19 Sep 2012 15:09:24 +0000 (15:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 19 Sep 2012 15:09:24 +0000 (15:09 +0000)
When building against eglibc, libc doesn't include librt therefore it must be explicitly included.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 33468

net/ntpd/Makefile

index 2147ea73788d0c19c1cdce26ae6d0d59142ba7fc..a1f17d77c5ad3adaaf5f50e27dbf20e7c57b218c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
 PKG_VERSION:=4.2.6p5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
@@ -30,7 +30,7 @@ define Package/ntpd/Default
   TITLE:=ISC ntp
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
   URL:=http://www.ntp.org/
-  DEPENDS:=+libcap
+  DEPENDS:=+libcap +USE_EGLIBC:librt
 endef
 
 define Package/ntpd/Default/description