mt76: drop default eeprom file for mt7986-firmware
authorChukun Pan <amadeus@jmu.edu.cn>
Thu, 4 May 2023 15:10:03 +0000 (23:10 +0800)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 7 Dec 2023 10:12:12 +0000 (11:12 +0100)
The mt76 driver usually reads the eeprom on the mtd partition at dts.
For emmc device we need to use caldata_extract script to read the
eeprom. However, the default eeprom file breaks the caldata script
execution, so remove it.

Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
(cherry picked from commit e3aa645b267ca4f08773b5366583e9b0020fc3e9)

package/kernel/mt76/Makefile

index 78f01c119fbfda61f601b24c55ec71ee45a12571..42075daecd52e21985f538a9a81481c3b252bc4e 100644 (file)
@@ -542,8 +542,6 @@ define KernelPackage/mt7986-firmware/install
                $(PKG_BUILD_DIR)/firmware/mt7986_wm.bin \
                $(PKG_BUILD_DIR)/firmware/mt7986_rom_patch_mt7975.bin \
                $(PKG_BUILD_DIR)/firmware/mt7986_rom_patch.bin \
-               $(PKG_BUILD_DIR)/firmware/mt7986_eeprom_mt7975_dual.bin \
-               $(PKG_BUILD_DIR)/firmware/mt7986_eeprom_mt7976_dual.bin \
                $(1)/lib/firmware/mediatek
 endef