iptables: fix libnftnl/IPTABLES_NFTABLES dependency
authorEtienne Champetier <champetier.etienne@gmail.com>
Sun, 27 Feb 2022 00:22:59 +0000 (19:22 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 20:52:01 +0000 (21:52 +0100)
libxtables doesn't depend on libnftnl, iptables-nft does,
so move the dependency to not pull libnftnl with firewall3/iptables-legacy

Also libxtables-nft depends on IPTABLES_NFTABLES

Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
package/network/utils/iptables/Makefile

index e936a57380f84a18e4375a1f7a66a1399658c8e4..12021c21f12dae32f87588f2a6f36d6e363ec8b0 100644 (file)
@@ -112,7 +112,7 @@ endef
 define Package/iptables-nft
 $(call Package/iptables/Default)
   TITLE:=IP firewall administration tool nft
-  DEPENDS:=@IPTABLES_NFTABLES +libxtables-nft +libip4tc +IPV6:libip6tc +kmod-ipt-core +kmod-nft-compat
+  DEPENDS:=@IPTABLES_NFTABLES +libnftnl +libxtables-nft +libip4tc +IPV6:libip6tc +kmod-ipt-core +kmod-nft-compat
   ALTERNATIVES:=\
     300:/usr/sbin/iptables:/usr/sbin/xtables-nft-multi \
     300:/usr/sbin/iptables-restore:/usr/sbin/xtables-nft-multi \
@@ -527,9 +527,7 @@ define Package/libxtables
  CATEGORY:=Libraries
  TITLE:=IPv4/IPv6 firewall - shared xtables library
  ABI_VERSION:=12
- DEPENDS:= \
-       +IPTABLES_CONNLABEL:libnetfilter-conntrack \
-       +IPTABLES_NFTABLES:libnftnl
+ DEPENDS:=+IPTABLES_CONNLABEL:libnetfilter-conntrack
 endef
 
 define Package/libxtables-nft
@@ -538,7 +536,7 @@ define Package/libxtables-nft
  CATEGORY:=Libraries
  TITLE:=IPv4/IPv6 firewall - shared xtables nft library
  ABI_VERSION:=12
- DEPENDS:=+libxtables
+ DEPENDS:=@IPTABLES_NFTABLES +libxtables
 endef
 
 TARGET_CPPFLAGS := \