strongswan: add missing library for the kernel-libipsec plugin
authorFelix Fietkau <nbd@openwrt.org>
Tue, 15 Apr 2014 17:11:47 +0000 (17:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 15 Apr 2014 17:11:47 +0000 (17:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40515

net/strongswan/Makefile

index 04c58e0f09e85f03f947cba8658e5de39da65af4..dd64966d458f17cfdc407a98a9c44d5f53449e95 100644 (file)
@@ -442,6 +442,11 @@ define Plugin/whitelist/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/plugins/libstrongswan-whitelist.so $(1)/usr/lib/ipsec/plugins/
 endef
 
+define Plugin/kernel-libipsec/install
+       $(INSTALL_DIR) $(1)/usr/lib/ipsec
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/libipsec.so.* $(1)/usr/lib/ipsec/
+endef
+
 $(eval $(call BuildPackage,strongswan))
 $(eval $(call BuildPackage,strongswan-default))
 $(eval $(call BuildPackage,strongswan-full))