armvirt: package and select Rockchip DWMAC Ethernet driver
authorMathew McBride <matt@traverse.com.au>
Tue, 18 Apr 2023 03:34:23 +0000 (03:34 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 13 Jun 2023 12:14:25 +0000 (14:14 +0200)
For devices that implement the "rockchip,*-gmac" compatible controller,
including:
- RK3328
- RK3399
- RK3568
- RK3588
- PX30

Signed-off-by: Mathew McBride <matt@traverse.com.au>
(cherry picked from commit abbffe55ddded36d2a4d0eee6e96c742eaffbbd2)

target/linux/armvirt/image/Makefile
target/linux/armvirt/modules.mk

index a4c0c17ec605df8c02075b9dfb23d70c2ce30a7d..e3031d5a138cf75a3fdb0c1cb0b2e08a0b54ea94 100644 (file)
@@ -109,8 +109,8 @@ define Device/generic
        kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
        kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
-       kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
-       kmod-phy-marvell-10g kmod-atlantic
+       kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
+       kmod-phy-marvell kmod-phy-marvell-10g kmod-atlantic
 endef
 TARGET_DEVICES += generic
 
index f94b25aad43b917ce5762a357b2bfd57d2a7daf5..5826c545b73ba2232e77b5458cfd0b82b4630c3f 100644 (file)
@@ -244,6 +244,17 @@ endef
 
 $(eval $(call KernelPackage,dwmac-sun8i))
 
+define KernelPackage/dwmac-rockchip
+  SUBMENU=$(NETWORK_DEVICES_MENU)
+  TITLE:=Rockchip RK3328/RK3399/RK3568 Ethernet
+  DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+  KCONFIG:=CONFIG_DWMAC_ROCKCHIP
+  FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-rk.ko
+  AUTOLOAD=$(call AutoLoad,45,dwmac-rk)
+endef
+
+$(eval $(call KernelPackage,dwmac-rockchip))
+
 define KernelPackage/thunderx-net
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Marvell (Cavium) ThunderX/2 network drivers