Add icon-naming-utils, hicolor-icon-theme and tango-icon-theme.
authorLars-Peter Clausen <lars@metafoo.de>
Sat, 17 Jan 2009 20:04:05 +0000 (20:04 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sat, 17 Jan 2009 20:04:05 +0000 (20:04 +0000)
SVN-Revision: 14076

desktop/data/hicolor-icon-theme/Makefile [new file with mode: 0644]
desktop/data/tango-icon-theme/Makefile [new file with mode: 0644]
desktop/tools/icon-naming-utils/Makefile [new file with mode: 0644]

diff --git a/desktop/data/hicolor-icon-theme/Makefile b/desktop/data/hicolor-icon-theme/Makefile
new file mode 100644 (file)
index 0000000..408a71f
--- /dev/null
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=hicolor-icon-theme
+PKG_VERSION:=0.10
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://icon-theme.freedesktop.org/releases/
+PKG_MD5SUM:=3534f7b8e59785c7d5bfa923e85510a7
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/hicolor-icon-theme
+  SECTION:=xorg-data
+  CATEGORY:=Xorg
+  SUBMENU:=data
+  TITLE:=freedesktop.org icon theme default layout
+  URL:=http://icon-theme.freedesktop.org/wiki/HicolorTheme
+endef
+
+define Package/hicolor-icon-theme/install
+       $(INSTALL_DIR) $(1)/usr/share/icons
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/icons/* $(1)/usr/share/icons/
+endef
+
+$(eval $(call BuildPackage,hicolor-icon-theme))
diff --git a/desktop/data/tango-icon-theme/Makefile b/desktop/data/tango-icon-theme/Makefile
new file mode 100644 (file)
index 0000000..82dead4
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tango-icon-theme
+PKG_VERSION:=0.8.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://tango.freedesktop.org/releases/
+PKG_MD5SUM:=32d5258f448b5982af9cfa4364f31d41
+PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=icon-naming-utils
+
+include $(INCLUDE_DIR)/package.mk
+
+
+define Package/tango-icon-theme
+  SECTION:=xorg-data
+  CATEGORY:=Xorg
+  SUBMENU:=data
+  TITLE:=Tango icon theme
+  URL:=http://tango.freedesktop.org/
+  DEPENDS:=+hicolor-icon-theme
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+           --disable-icon-framing \
+       )
+endef
+
+define Package/tango-icon-theme/install
+       $(INSTALL_DIR) $(1)/usr/share/icons
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/icons/* \
+               $(1)/usr/share/icons/
+endef
+
+$(eval $(call BuildPackage,tango-icon-theme))
diff --git a/desktop/tools/icon-naming-utils/Makefile b/desktop/tools/icon-naming-utils/Makefile
new file mode 100644 (file)
index 0000000..36b2ac1
--- /dev/null
@@ -0,0 +1,54 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=icon-naming-utils
+PKG_VERSION:=0.8.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://tango.freedesktop.org/releases/
+PKG_MD5SUM:=2bcd77b8b6361831a932a5e76e82b66d
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/icon-naming-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Tool for generating icon themes
+  URL:=http://tango.freedesktop.org/
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --libexecdir=/lib/icon-naming-utils \
+       )
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(2)/lib/icon-naming-utils
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/lib/icon-naming-utils/icon-name-mapping \
+               $(2)/lib/icon-naming-utils/
+       $(SED) \
+               's,/usr/share/icon-naming-utils,$(STAGING_DIR)/host/share/icon-naming-utils,g' \
+               $(2)/lib/icon-naming-utils/icon-name-mapping
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+       $(SED) \
+               's,^program_path=,program_path=$(STAGING_DIR)/host,g' \
+               $(1)/usr/lib/pkgconfig/icon-naming-utils.pc
+
+       $(INSTALL_DIR) $(2)/share/icon-naming-utils/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/icon-naming-utils/* \
+               $(2)/share/icon-naming-utils/
+endef
+
+define Package/icon-naming-utils/install
+       true
+endef
+
+$(eval $(call BuildPackage,icon-naming-utils))