qualcommax: only build initramfs if CONFIG_TARGET_ROOTFS_INITRAMFS is set
authorFlorian Maurer <f.maurer@outlook.de>
Thu, 26 Oct 2023 06:40:59 +0000 (08:40 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 30 Oct 2023 23:44:03 +0000 (00:44 +0100)
This makes it possible to build the ipq807x netgear-wax218 without initramfs - which is required for downstream projects (gluon)

Signed-off-by: Florian Maurer <f.maurer@outlook.de>
(cherry picked from commit b3d2008f92f15ff776ad6c4f6d113b0cda1bd2d0)

target/linux/ipq807x/image/generic.mk

index 124cdfc3b2a54e985d1cd499edcc2da557b084f8..fb991156d5de4b740dacdae0d4ea612d3b7ec1cc 100644 (file)
@@ -80,15 +80,17 @@ TARGET_DEVICES += edimax_cax1800
 define Device/netgear_wax218
        $(call Device/FitImage)
        $(call Device/UbiFit)
-       ARTIFACTS := web-ui-factory.fit
        DEVICE_VENDOR := Netgear
        DEVICE_MODEL := WAX218
        DEVICE_DTS_CONFIG := config@hk07
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := ipq8072
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       ARTIFACTS := web-ui-factory.fit
        ARTIFACT/web-ui-factory.fit := append-image initramfs-uImage.itb | \
                ubinize-kernel | qsdk-ipq-factory-nand
+endif
        DEVICE_PACKAGES := kmod-spi-gpio kmod-spi-bitbang kmod-gpio-nxp-74hc164 \
                ipq-wifi-netgear_wax218
 endef