use .$(LINUX_KMOD_SUFFIX) instead of .ko in AutoLoad (closes: #5452)
authorNicolas Thill <nico@openwrt.org>
Tue, 7 Jul 2009 02:11:11 +0000 (02:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 7 Jul 2009 02:11:11 +0000 (02:11 +0000)
SVN-Revision: 16726

package/kernel/modules/netfilter.mk

index 91c326518664eba95f016fd3d6c0e31b1518315c..5c9a834fe7f64ef76ca5195f380a2c0666f765fa 100644 (file)
@@ -375,7 +375,7 @@ define KernelPackage/arptables
   TITLE:=ARP firewalling modules
   FILES:=$(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_IP_NF_ARPTABLES
-  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)))))
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.$(LINUX_KMOD_SUFFIX),%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)))))
 endef
 
 define KernelPackage/arptables/description
@@ -391,7 +391,7 @@ define KernelPackage/ebtables
   FILES:=$(LINUX_DIR)/net/bridge/netfilter/*.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
        CONFIG_BRIDGE_NF_EBTABLES
-  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,ebtables.ko $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebtable_*.$(LINUX_KMOD_SUFFIX)) $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebt_*.$(LINUX_KMOD_SUFFIX)))))
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.$(LINUX_KMOD_SUFFIX),%,ebtables.$(LINUX_KMOD_SUFFIX) $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebtable_*.$(LINUX_KMOD_SUFFIX)) $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebt_*.$(LINUX_KMOD_SUFFIX)))))
 endef
 
 define KernelPackage/ebtables/description