fwknop: update to 2.0, use new startup commands Signed-off-by: Jonathan Bennett ...
authorStephen Walker <stephendwalker@gmail.com>
Sun, 20 May 2012 01:45:42 +0000 (01:45 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 20 May 2012 01:45:42 +0000 (01:45 +0000)
SVN-Revision: 31824

net/fwknop/Makefile
net/fwknop/patches/001-fix_config.patch
net/fwknop/patches/002-fix_init.patch [new file with mode: 0644]

index d4778d35f222e26f88cef698df0ac03c2ad71a28..24d7385e5bfffc03971fd42fdef902abc09047df 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fwknop
-PKG_VERSION:=2.0.0rc4
+PKG_VERSION:=2.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.cipherdyne.org/fwknop/download
-PKG_MD5SUM:=4f5d45187429ca56d3b444ab96c57fb6
+PKG_MD5SUM:=96de4c5a4ae75a8618ef80269c6a70ad
 
 PKG_INSTALL:=1
 
index e11ae07df90ae84332bfddb3ed70163eb58591ec..5ae4a94852b9d99eef1d8efacac9f8db120026c8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/server/fwknopd.conf
 +++ b/server/fwknopd.conf
-@@ -30,7 +30,12 @@
+@@ -29,7 +29,12 @@
  # Define the ethernet interface on which we will sniff packets.
  # Default if not set is eth0.
  #
@@ -14,7 +14,7 @@
  
  # By default fwknopd does not put the pcap interface into promiscuous mode.
  # Set this to 'Y' to enable promiscuous sniffing.
-@@ -239,8 +244,13 @@
+@@ -252,8 +257,13 @@
  # The IPT_FORWARD_ACCESS variable is only used if ENABLE_IPT_FORWARDING is
  # enabled.
  #
diff --git a/net/fwknop/patches/002-fix_init.patch b/net/fwknop/patches/002-fix_init.patch
new file mode 100644 (file)
index 0000000..9efda57
--- /dev/null
@@ -0,0 +1,17 @@
+--- a/extras/openwrt/package/fwknop/files/fwknopd.init
++++ b/extras/openwrt/package/fwknop/files/fwknopd.init
+@@ -8,12 +8,12 @@ FWKNOPD_BIN=/usr/sbin/fwknopd
+ start()
+ {
+-      $FWKNOPD_BIN
++      service_start $FWKNOPD_BIN
+ }
+ stop()
+ {
+-      $FWKNOPD_BIN -K
++      service_stop $FWKNOPD_BIN -K
+ }
+ restart()