trusty: Require dynamic translation tables
authorAntonio Nino Diaz <antonio.ninodiaz@arm.com>
Wed, 6 Feb 2019 13:27:52 +0000 (13:27 +0000)
committerAntonio Nino Diaz <antonio.ninodiaz@arm.com>
Wed, 6 Feb 2019 13:35:15 +0000 (13:35 +0000)
Trusty requires dynamic translation tables support, so the makefile of
Trusty itself should request it. Not doing so causes platforms such as
FVP to fail to build with Trusty. Other platforms like Tegra still build
because they use dynamic translation tables by default.

Change-Id: Id67d3b9e1f7d0547fa81e81cefa3faf1e0e6f876
Signed-off-by: Antonio Nino Diaz <antonio.ninodiaz@arm.com>
services/spd/trusty/trusty.mk

index a571fa2cdb5ee959e3a73d87d2818bb39a4f2f81..4f0c294763552ec2a5c255b04925d82e14c4b12d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+# Copyright (c) 2016-2019, ARM Limited and Contributors. All rights reserved.
 #
 # SPDX-License-Identifier: BSD-3-Clause
 #
@@ -13,6 +13,8 @@ ifeq (${TRUSTY_SPD_WITH_GENERIC_SERVICES},1)
 SPD_SOURCES            +=      services/spd/trusty/generic-arm64-smcall.c
 endif
 
+BL31_CFLAGS    +=              -DPLAT_XLAT_TABLES_DYNAMIC=1
+
 NEED_BL32              :=      yes
 
 CTX_INCLUDE_FPREGS     :=      1