baresip: fix avformat & v4l bustage
authorStephen Walker <stephendwalker@gmail.com>
Mon, 27 Feb 2012 04:29:18 +0000 (04:29 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Mon, 27 Feb 2012 04:29:18 +0000 (04:29 +0000)
SVN-Revision: 30736

net/baresip/Makefile
net/baresip/patches/100-avcodec-compat.patch [deleted file]
net/baresip/patches/100-videodev-compat.patch [new file with mode: 0644]

index d3ec1c61a01bfd6f9fc9d5494c6da6b5ea003e14..12e4de8a5a38bed966a5bce08481841db8c67737 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2010-2011 OpenWrt.org
+#
+# Copyright (C) 2010-2012 OpenWrt.org
 # Copyright (C) 2010 Alfred E. Heggestad
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=baresip
 PKG_VERSION:=0.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub/
@@ -145,5 +145,5 @@ $(eval $(call BuildPlugin,oss,OSS audio driver,oss,))
 $(eval $(call BuildPlugin,speex,Speex audio codec,speex,+PACKAGE_baresip-mod-speex:libspeex))
 $(eval $(call BuildPlugin,stdio,standard I/O UI,stdio,))
 $(eval $(call BuildPlugin,uuid,UUID,uuid,+libuuid))
-$(eval $(call BuildPlugin,v4l,Video4Linux video source,v4l,+PACKAGE_baresip-mod-v4l:libv4l @(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_33||LINUX_2_6_34||LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37)))
-$(eval $(call BuildPlugin,v4l2,Video4Linux2 video source,v4l2,+PACKAGE_baresip-mod-v4l2:libv4l @(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_33||LINUX_2_6_34||LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37)))
+$(eval $(call BuildPlugin,v4l,Video4Linux video source,v4l,+PACKAGE_baresip-mod-v4l:libv4l))
+$(eval $(call BuildPlugin,v4l2,Video4Linux2 video source,v4l2,+PACKAGE_baresip-mod-v4l2:libv4l))
diff --git a/net/baresip/patches/100-avcodec-compat.patch b/net/baresip/patches/100-avcodec-compat.patch
deleted file mode 100644 (file)
index 2f412d6..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/modules/avformat/avf.c
-+++ b/modules/avformat/avf.c
-@@ -27,10 +27,7 @@
- /* backward compat */
--#if defined (CODEC_TYPE_VIDEO)
--#undef  AVMEDIA_TYPE_VIDEO
- #define AVMEDIA_TYPE_VIDEO CODEC_TYPE_VIDEO
--#endif
- struct vidsrc_st {
diff --git a/net/baresip/patches/100-videodev-compat.patch b/net/baresip/patches/100-videodev-compat.patch
new file mode 100644 (file)
index 0000000..4b9997c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/modules/v4l/v4l.c
++++ b/modules/v4l/v4l.c
+@@ -14,7 +14,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #undef __STRICT_ANSI__ /* needed for RHEL4 kernel 2.6.9 */
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+ #include <pthread.h>
+ #include <re.h>
+ #include <baresip.h>