mediatek: mt7623: build SD card without all filesystems
authorDaniel Golle <daniel@makrotopia.org>
Mon, 22 May 2023 21:58:58 +0000 (22:58 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 24 May 2023 18:26:41 +0000 (19:26 +0100)
Allow building SD card images without having both initramfs and squashfs
present on the card, just like it has already been done for the mt7622
and filogic subtargets.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit d6fef27f2dd4a852ed7846e4aa5f06dcd8df91b6)

target/linux/mediatek/image/mt7623.mk

index 26befc1c1e533eeb4befc59652604c036ff7cd43..1645ecd545075608cfa6516ba7f86113521c122d 100644 (file)
@@ -104,8 +104,12 @@ define Device/bananapi_bpi-r2
                            pad-to 2k | append-preloader $$(UBOOT_TARGET) |\
                            pad-to $$(UBOOT_OFFSET) | append-bootloader $$(UBOOT_TARGET) |\
                            pad-to 4092k | mt7623-mbr emmc |\
+                           $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
                            pad-to 4M | append-image-stage initramfs-recovery.itb |\
+                           ) \
+                           $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
                            pad-to 48M | append-image squashfs-sysupgrade.itb |\
+                           ) \
                            gzip
   ARTIFACTS := u-boot.bin preloader.bin sdcard.img.gz
   SUPPORTED_DEVICES := bananapi,bpi-r2
@@ -135,8 +139,12 @@ define Device/unielec_u7623-02
 # but OpenWrt expects 'SDMM' magic for sysupgrade.
   ARTIFACT/emmc.img.gz := mt7623-mbr sdmmc |\
                            pad-to $$(UBOOT_OFFSET) | append-bootloader $$(UBOOT_TARGET) |\
+                           $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
                            pad-to 4M | append-image-stage initramfs-recovery.itb |\
+                           ) \
+                           $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
                            pad-to 48M | append-image squashfs-sysupgrade.itb |\
+                           ) \
                            gzip | append-metadata
   ARTIFACT/scatter.txt := scatterfile emmc.img.gz
   ARTIFACTS := u-boot.bin scatter.txt emmc.img.gz