libjson-c: disable libbsd
authorRosen Penev <rosenp@gmail.com>
Mon, 4 Jul 2022 07:56:19 +0000 (00:56 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 4 Jul 2022 18:37:41 +0000 (20:37 +0200)
libjson-c is happy to pick up libbsd both on the host and target.
Reproducible with

make package/libbsd/compile;make package/libjson-c/compile

Also fixes host compilation on Arch Linux for a similar reason.
Undefined reference to arc4random.

Fixes: f3a198697f60 ("libjson-c: update to 0.16")
Acked-by: Thomas Huehn thomas.huehn@hs-nordhausen.de
Acked-by: Nick Hainke vincent@systemli.org
Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/libjson-c/Makefile

index 2b90c27a4a899cff42f3c4304b73094595069e3e..2c312f200eecf7c2b6536401520a6e0e75ce2d8f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=json-c
 PKG_VERSION:=0.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
 PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
@@ -27,8 +27,12 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_HOST_OPTIONS += \
+       -DDISABLE_EXTRA_LIBS=TRUE \
        -DBUILD_SHARED_LIBS=FALSE
 
+CMAKE_OPTIONS += \
+       -DDISABLE_EXTRA_LIBS=TRUE
+
 define Package/libjson-c
   SECTION:=libs
   CATEGORY:=Libraries