kernel: bump 4.14 to 4.14.267
authorPetr Štetiar <ynezz@true.cz>
Wed, 16 Feb 2022 16:50:59 +0000 (17:50 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 16 Feb 2022 20:47:59 +0000 (21:47 +0100)
All patches refreshed automagically without conflicts, but test builds
choked on new BPF_UNPRIV_DEFAULT_OFF kernel config symbol introduced in
upstream commit e69f08ba23a3 ("bpf: Add kconfig knob for disabling
unpriv bpf by default").

Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/config-4.14
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/generic/pending-4.14/920-mangle_bootargs.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch

index 466d3d76d96cc7f7c3ae35cd0287867836d50220..e226bc4d9105264441f57c29586bd8b64a505ff5 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .266
+LINUX_VERSION-4.14 = .267
 
-LINUX_KERNEL_HASH-4.14.266 = 4f0e1377efd969f9117edd06e749415f1d636bc012533df170d46c89f8c7cf58
+LINUX_KERNEL_HASH-4.14.267 = 8c343f885cfe25a51a8d40595afe5268ce09eaf8f531f9546ecf20831924188e
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d813aa42c99e12e6d62fe861846c43d6f7db14ce..7e96f20a51e7e2cd5e011d61d9e0d7961d1f0c4b 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2058,7 +2058,8 @@ static const struct usb_device_id option
+@@ -2060,7 +2060,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index cbe2c09af91dcbb036bb71d42b6b1075d7f31012..93f080229ad167c8781caf62a3a71fbc0d2d6f22 100644 (file)
@@ -601,6 +601,7 @@ CONFIG_BPF_JIT=y
 # CONFIG_BPF_JIT_ALWAYS_ON is not set
 # CONFIG_BPF_STREAM_PARSER is not set
 CONFIG_BPF_SYSCALL=y
+# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
 # CONFIG_BPQETHER is not set
 CONFIG_BQL=y
 CONFIG_BRANCH_PROFILE_NONE=y
index a8619edbfc377a1368221c7d4c012a5eb5f5288a..d6f7d9fa678e7c9a78a32a28bba835ef155b7f8e 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1903,6 +1903,13 @@ config TRIM_UNUSED_KSYMS
+@@ -1913,6 +1913,13 @@ config TRIM_UNUSED_KSYMS
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
index 2f6a52c23d65b61678cfbbcbbe23b2f5a923a02b..cd245ad66306eebbdb0feb788e3dd15c055bbcc7 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1427,6 +1427,15 @@ config EMBEDDED
+@@ -1437,6 +1437,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
index f8b858aed2b48d1a0965208efe8fce052c5378c9..47525dd8ec2e416b1354f22dca4373f8752e204d 100644 (file)
@@ -528,7 +528,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
                reg &= ~DWC3_DCTL_INITU2ENA;
 --- a/drivers/usb/dwc3/gadget.c
 +++ b/drivers/usb/dwc3/gadget.c
-@@ -3244,6 +3244,7 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3257,6 +3257,7 @@ int dwc3_gadget_init(struct dwc3 *dwc)
  {
        int ret;
        int irq;
@@ -536,7 +536,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
  
        irq = dwc3_gadget_get_irq(dwc);
        if (irq < 0) {
-@@ -3322,6 +3323,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3335,6 +3336,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
  
        dwc3_gadget_set_speed(&dwc->gadget, dwc->maximum_speed);
  
index 746391a31f202aeee72878ac5745e8584f9adae9..34c754dc4afc045744e2efb6d9a58541496961ef 100644 (file)
@@ -131,7 +131,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  };
  
  /**
-@@ -500,13 +550,20 @@ static void esdhc_clock_enable(struct sd
+@@ -504,13 +554,20 @@ static void esdhc_clock_enable(struct sd
        }
  }
  
@@ -152,7 +152,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        u32 temp;
  
        host->mmc->actual_clock = 0;
-@@ -520,27 +577,14 @@ static void esdhc_of_set_clock(struct sd
+@@ -524,27 +581,14 @@ static void esdhc_of_set_clock(struct sd
        if (esdhc->vendor_ver < VENDOR_V_23)
                pre_div = 2;
  
@@ -187,7 +187,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  
        temp = sdhci_readl(host, ESDHC_SYSTEM_CONTROL);
        temp &= ~(ESDHC_CLOCK_SDCLKEN | ESDHC_CLOCK_IPGEN | ESDHC_CLOCK_HCKEN |
-@@ -553,9 +597,30 @@ static void esdhc_of_set_clock(struct sd
+@@ -557,9 +601,30 @@ static void esdhc_of_set_clock(struct sd
        while (host->max_clk / pre_div / div > clock && div < 16)
                div++;
  
@@ -218,7 +218,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        pre_div >>= 1;
        div--;
  
-@@ -565,6 +630,29 @@ static void esdhc_of_set_clock(struct sd
+@@ -569,6 +634,29 @@ static void esdhc_of_set_clock(struct sd
                | (pre_div << ESDHC_PREDIV_SHIFT));
        sdhci_writel(host, temp, ESDHC_SYSTEM_CONTROL);
  
@@ -248,7 +248,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        /* Wait max 20 ms */
        timeout = ktime_add_ms(ktime_get(), 20);
        while (1) {
-@@ -580,6 +668,7 @@ static void esdhc_of_set_clock(struct sd
+@@ -584,6 +672,7 @@ static void esdhc_of_set_clock(struct sd
                udelay(10);
        }
  
@@ -256,7 +256,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        temp |= ESDHC_CLOCK_SDCLKEN;
        sdhci_writel(host, temp, ESDHC_SYSTEM_CONTROL);
  }
-@@ -608,6 +697,8 @@ static void esdhc_pltfm_set_bus_width(st
+@@ -612,6 +701,8 @@ static void esdhc_pltfm_set_bus_width(st
  
  static void esdhc_reset(struct sdhci_host *host, u8 mask)
  {
@@ -265,7 +265,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        u32 val;
  
        sdhci_reset(host, mask);
-@@ -619,6 +710,12 @@ static void esdhc_reset(struct sdhci_hos
+@@ -623,6 +714,12 @@ static void esdhc_reset(struct sdhci_hos
                val = sdhci_readl(host, ESDHC_TBCTL);
                val &= ~ESDHC_TB_EN;
                sdhci_writel(host, val, ESDHC_TBCTL);
@@ -278,7 +278,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        }
  }
  
-@@ -630,6 +727,7 @@ static void esdhc_reset(struct sdhci_hos
+@@ -634,6 +731,7 @@ static void esdhc_reset(struct sdhci_hos
  static const struct of_device_id scfg_device_ids[] = {
        { .compatible = "fsl,t1040-scfg", },
        { .compatible = "fsl,ls1012a-scfg", },
@@ -286,7 +286,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        { .compatible = "fsl,ls1046a-scfg", },
        {}
  };
-@@ -692,23 +790,91 @@ static int esdhc_signal_voltage_switch(s
+@@ -696,23 +794,91 @@ static int esdhc_signal_voltage_switch(s
        }
  }
  
@@ -383,7 +383,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  }
  
  #ifdef CONFIG_PM_SLEEP
-@@ -757,7 +923,7 @@ static const struct sdhci_ops sdhci_esdh
+@@ -761,7 +927,7 @@ static const struct sdhci_ops sdhci_esdh
        .adma_workaround = esdhc_of_adma_workaround,
        .set_bus_width = esdhc_pltfm_set_bus_width,
        .reset = esdhc_reset,
@@ -392,7 +392,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  };
  
  static const struct sdhci_ops sdhci_esdhc_le_ops = {
-@@ -774,7 +940,7 @@ static const struct sdhci_ops sdhci_esdh
+@@ -778,7 +944,7 @@ static const struct sdhci_ops sdhci_esdh
        .adma_workaround = esdhc_of_adma_workaround,
        .set_bus_width = esdhc_pltfm_set_bus_width,
        .reset = esdhc_reset,
@@ -401,7 +401,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  };
  
  static const struct sdhci_pltfm_data sdhci_esdhc_be_pdata = {
-@@ -800,8 +966,20 @@ static struct soc_device_attribute soc_i
+@@ -804,8 +970,20 @@ static struct soc_device_attribute soc_i
        { },
  };
  
@@ -422,7 +422,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        struct sdhci_pltfm_host *pltfm_host;
        struct sdhci_esdhc *esdhc;
        struct device_node *np;
-@@ -821,6 +999,24 @@ static void esdhc_init(struct platform_d
+@@ -825,6 +1003,24 @@ static void esdhc_init(struct platform_d
        else
                esdhc->quirk_incorrect_hostver = false;
  
@@ -447,7 +447,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        np = pdev->dev.of_node;
        clk = of_clk_get(np, 0);
        if (!IS_ERR(clk)) {
-@@ -848,6 +1044,12 @@ static void esdhc_init(struct platform_d
+@@ -852,6 +1048,12 @@ static void esdhc_init(struct platform_d
        }
  }
  
@@ -460,7 +460,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  static int sdhci_esdhc_probe(struct platform_device *pdev)
  {
        struct sdhci_host *host;
-@@ -871,6 +1073,7 @@ static int sdhci_esdhc_probe(struct plat
+@@ -875,6 +1077,7 @@ static int sdhci_esdhc_probe(struct plat
        host->mmc_host_ops.start_signal_voltage_switch =
                esdhc_signal_voltage_switch;
        host->mmc_host_ops.execute_tuning = esdhc_execute_tuning;
@@ -468,7 +468,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        host->tuning_delay = 1;
  
        esdhc_init(pdev, host);
-@@ -879,6 +1082,11 @@ static int sdhci_esdhc_probe(struct plat
+@@ -883,6 +1086,11 @@ static int sdhci_esdhc_probe(struct plat
  
        pltfm_host = sdhci_priv(host);
        esdhc = sdhci_pltfm_priv(pltfm_host);
@@ -480,7 +480,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
        if (esdhc->vendor_ver == VENDOR_V_22)
                host->quirks2 |= SDHCI_QUIRK2_HOST_NO_CMD23;
  
-@@ -925,14 +1133,6 @@ static int sdhci_esdhc_probe(struct plat
+@@ -929,14 +1137,6 @@ static int sdhci_esdhc_probe(struct plat
        return ret;
  }