samba: merge r29199, r29251
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:06:16 +0000 (16:06 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:06:16 +0000 (16:06 +0000)
SVN-Revision: 30255

net/samba/Makefile

index 28c2bd7678a6f628d272654b1fefde5a8e8b1af2..d02c6801959d35ac138d945c3134749cff914a60 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=2.0.10
-PKG_RELEASE:=6
-PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
+PKG_RELEASE:=8
 
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,7 +36,6 @@ define Package/samba2-common
   $(call Package/samba)
   MENU:=1
   TITLE:=NetBIOS/SMB server and client shared files
-  DEPENDS:=+libgcc
 endef
 
 define Package/samba2-server
@@ -189,6 +188,10 @@ define Package/samba2-common/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R,1251} $(1)/usr/share/samba/
 endef
 
+define Package/samba2-common/conffiles
+/etc/samba/smb.conf
+endef
+
 define Package/samba2-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba