mocp: moved to github
authorSteven Barth <cyrus@openwrt.org>
Fri, 1 Aug 2014 08:37:05 +0000 (08:37 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 1 Aug 2014 08:37:05 +0000 (08:37 +0000)
SVN-Revision: 41924

sound/mocp/Makefile [deleted file]

diff --git a/sound/mocp/Makefile b/sound/mocp/Makefile
deleted file mode 100644 (file)
index 8f866e5..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=moc
-PKG_VERSION:=2.5.0-beta2
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ftp.daper.net/pub/soft/moc/unstable/
-PKG_MD5SUM:=da87b90b57934234589b63e347921458
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/nls.mk
-
-define Package/moc
-  SECTION:=sound
-  CATEGORY:=Sound
-  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg +libltdl +libmagic +faad2 +libdb47
-  TITLE:=Music On Console
-  URL:=http://moc.daper.net/
-endef
-
-define Package/moc/description
-       MOC (music on console) is a console audio player for LINUX/UNIX designed to be powerful and easy to use.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               $(if $(CONFIG_BUILD_PATENTED),,--without-mp3) \
-               --enable-shared \
-               --disable-static \
-               --disable-debug \
-               --without-speex \
-               --without-samplerate \
-               --without-curl \
-               --without-flac \
-               --without-musepack \
-               --without-rcc \
-               $(if $(CONFIG_PACKAGE_libncursesw),--with-ncursesw --without-ncurses,--with-ncurses --without-ncursesw) \
-       )
-endef
-
-define Package/moc/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mocp $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/lib/moc/decoder_plugins
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/moc/decoder_plugins/*.so $(1)/usr/lib/moc/decoder_plugins
-endef
-
-$(eval $(call BuildPackage,moc))