ramips: mt7621: enable lzma-loader for ZyXEL WAP6805
authorBjørn Mork <bjorn@mork.no>
Mon, 28 Nov 2022 14:45:12 +0000 (15:45 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 6 Dec 2022 22:29:42 +0000 (23:29 +0100)
Fixing "Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board
to recover".

Signed-off-by: Bjørn Mork <bjorn@mork.no>
(cherry picked from commit 8719f73fa2beddb259013801ca912b96fbc83543)

target/linux/ramips/image/mt7621.mk

index ab131658e064f94651057d0409942b7b7133a346..2907d90dab5fdd22d58b8f4fa85fd3df4610126d 100644 (file)
@@ -2232,6 +2232,7 @@ TARGET_DEVICES += zyxel_nwa55axe
 
 define Device/zyxel_wap6805
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   KERNEL_SIZE := 4096k
@@ -2240,7 +2241,7 @@ define Device/zyxel_wap6805
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := WAP6805
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7621-qtn-rgmii
-  KERNEL := $(KERNEL_DTB) | uImage lzma | uimage-padhdr 160
+  KERNEL := $$(KERNEL/lzma-loader) | uImage none | uimage-padhdr 160
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 TARGET_DEVICES += zyxel_wap6805