mediatek: switch to use seperate ramdisk for initramfs images
authorDaniel Golle <daniel@makrotopia.org>
Thu, 25 Feb 2021 14:51:41 +0000 (14:51 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 25 Feb 2021 16:39:55 +0000 (16:39 +0000)
MediaTek targets always use U-Boot's modern uImage.FIT format which
allows bundling several blobs into a single file including hashes,
descriptions and more. In fact, we are already using that to bundle
the Flattened Device Tree blob with the kernel on this and many
other targets.
In the same fashion, we can now make use of the newly introduced
support for building seperate ramdisk to uImage.FIT with a dedicated
initrd blob checked and loaded by U-Boot instead of embedding the
cpio archive into the kernel itself.
This allows for having larger ramdisks, choosing ramdisk compression
independently of kernel compression (while only kernel is decompressed
by the bootloader) and for more easily replacing or modifying the
filesystem contained in an initramfs image.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/Makefile
target/linux/mediatek/image/Makefile

index c8ab5e01e6d45f91901418f28e0274bc5f574bda..ceea84f8a8bc33903327432fa822b353a6782752 100644 (file)
@@ -6,7 +6,7 @@ ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 SUBTARGETS:=mt7622 mt7623 mt7629
-FEATURES:=squashfs nand ramdisk fpu
+FEATURES:=squashfs nand seperate_ramdisk fpu
 
 KERNEL_PATCHVER:=5.4
 KERNEL_TESTING_PATCHVER:=5.4
index 45e83cece5e559338310307fe8ff68329e490892..7aa7a7285c3fb20c36e5650b7dc37e352772dfa1 100644 (file)
@@ -23,7 +23,7 @@ define Device/Default
   KERNEL = kernel-bin | lzma | \
        fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
   KERNEL_INITRAMFS = kernel-bin | lzma | \
-       fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+       fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
   FILESYSTEMS := squashfs
   DEVICE_DTS_DIR := $(DTS_DIR)
   IMAGES := sysupgrade.bin