strongswan: add missing dependencies for eap-mschapv2 (#15135)
authorFelix Fietkau <nbd@openwrt.org>
Wed, 5 Mar 2014 10:46:38 +0000 (10:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 5 Mar 2014 10:46:38 +0000 (10:46 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39776

net/strongswan/Makefile

index 6ea62f96736099fc451927fcd5c9f8172960f5ef..1586b51a4658be21f6a38221dec713e13a27d98b 100644 (file)
@@ -469,7 +469,7 @@ $(eval $(call BuildPlugin,dnskey,DNS RR key decoding,))
 $(eval $(call BuildPlugin,duplicheck,advanced duplicate checking,))
 $(eval $(call BuildPlugin,eap-identity,EAP identity helper,))
 $(eval $(call BuildPlugin,eap-md5,EAP MD5 (CHAP) EAP auth,))
-$(eval $(call BuildPlugin,eap-mschapv2,EAP MS-CHAPv2 EAP auth,))
+$(eval $(call BuildPlugin,eap-mschapv2,EAP MS-CHAPv2 EAP auth,+strongswan-mod-md4 +strongswan-mod-des))
 $(eval $(call BuildPlugin,eap-radius,EAP RADIUS auth,))
 $(eval $(call BuildPlugin,farp,fake arp respsonses,))
 $(eval $(call BuildPlugin,fips-prf,FIPS PRF crypto,+strongswan-mod-sha1))