AA: build: Add TARGET_ROOTFS_RESERVED_PCT option to reduce wasted space
authorGabor Juhos <juhosg@openwrt.org>
Thu, 29 Nov 2012 17:49:50 +0000 (17:49 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 29 Nov 2012 17:49:50 +0000 (17:49 +0000)
Backport of r34408.

The genext2fs tool will 'reserve' 5% of the image size by default,
apparently by creating a huge lost+found directory. In fact it seemed to
be much more than 5% in practice — I saw an image with 8MiB used, and
recovered about 2MiB of it by deleting the 'empty' lost+found directory:

/dev/loop0         48377  8482     37438  19% /mnt/spare
 # rmdir lost+found/
/dev/loop0         48377  6014     39906  14% /mnt/spare

This makes it configurable, but leaves it at the genext2fs default
of 5% for now. It should probably be changed to default to zero, but
that can be a separate patch.

Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34412

Config.in
include/image.mk

index bd4f63ea43f8647048744826a15ac7331bf479ab..19c8edfb9d3a2baf2717e1a964bccd6e913ba23f 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -124,6 +124,13 @@ menu "Target Images"
                help
                    Allows you to change the maximum number of inodes in the root filesystem
 
+       config TARGET_ROOTFS_RESERVED_PCT
+               int "Percentage of reserved blocks in root filesystem"
+               depends TARGET_ROOTFS_EXT4FS
+               default 5
+               help
+                   Allows you to change the percentage of reserved blocks in the root filesystem
+
 endmenu
 
 menu "Global build settings"
index 1977fc84c0436cdffd7779d529ef8ea4e11266c5..f0d2ee664a17ab4f620f9a1e7b3b7968b49c136a 100644 (file)
@@ -124,7 +124,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
 
   define Image/mkfs/ext4
 # generate an ext2 fs
-       $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4
+       $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT)
 # convert it to ext4
        $(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
 # fix it up