oww: add oww, a 1-wire weather util
authorStephen Walker <stephendwalker@gmail.com>
Sat, 18 Feb 2012 02:14:25 +0000 (02:14 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sat, 18 Feb 2012 02:14:25 +0000 (02:14 +0000)
SVN-Revision: 30625

utils/oww/Makefile [new file with mode: 0644]
utils/oww/files/oww.init [new file with mode: 0644]

diff --git a/utils/oww/Makefile b/utils/oww/Makefile
new file mode 100644 (file)
index 0000000..ee0b522
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=oww
+PKG_VERSION:=0.84.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/oww
+PKG_MD5SUM:=1fff042b4f482c2978c14765bb1d813f
+
+PKG_BUILD_DEPENDS:=intltool/host
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/oww
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=One-wire weather
+  URL:=http://oww.sourceforge.net/
+  DEPENDS:=+libcurl +libusb
+endef
+
+define Package/oww/description
+  Oww is a software project, to communicate with the Dallas 1-wire weather
+  station and other 1-wire sensors, presenting live weather readings, logging
+  data to file, uploading data to weather Web sites, and sending data to other
+  programs through a command line interface.
+endef
+
+CONFIGURE_ARGS += \
+       --disable-gui
+
+define Package/oww/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/oww.init $(1)/etc/init.d/oww
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/owwnogui $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,oww))
diff --git a/utils/oww/files/oww.init b/utils/oww/files/oww.init
new file mode 100644 (file)
index 0000000..74684c6
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+
+START=65
+
+SERVICE_DAEMONIZE=1
+
+start() {
+       service_start /usr/bin/owwnogui
+}
+
+stop() {
+       service_stop /usr/bin/owwnogui
+}