kernel: bump 4.9 to 4.9.167
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 5 Apr 2019 10:07:38 +0000 (12:07 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 10:11:59 +0000 (12:11 +0200)
Refreshed all patches.

Compile-test on: ar71xx
Runtime-test on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 04582dbca38c689d6423796c482021a0d7ea9e22..330bf51643cbae5bded4d716efa54aec8abdc794 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .166
+LINUX_VERSION-4.9 = .167
 LINUX_VERSION-4.14 = .109
 
-LINUX_KERNEL_HASH-4.9.166 = b8f87c087cbc35d35d55cae1c0c7e47c8d20226d241697bf5d4c0c524439baeb
+LINUX_KERNEL_HASH-4.9.167 = a2b8608a2fe7a6203ed46c3a3d55091b19ac8304dded6338410a361dc63f0a8c
 LINUX_KERNEL_HASH-4.14.109 = 3764f165f779568745f1468d8f7e1db65d94eae9cd8d1350f4fe003a0fd88ee0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3ac2ad310249446bc1b1f9546f2f17f203c09c52..c1aff504753cab7ef7cb7e2a4faed1746afb470c 100644 (file)
@@ -1439,7 +1439,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -1852,14 +1852,17 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1855,14 +1855,17 @@ static int finish_td(struct xhci_hcd *xh
        union xhci_trb *event_trb, struct xhci_transfer_event *event,
        struct xhci_virt_ep *ep, int *status, bool skip)
  {
@@ -1457,7 +1457,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        u32 trb_comp_code;
  
        slot_id = TRB_TO_SLOT_ID(le32_to_cpu(event->flags));
-@@ -1885,13 +1888,29 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1888,13 +1891,29 @@ static int finish_td(struct xhci_hcd *xh
        if (trb_comp_code == COMP_STALL ||
                xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
                                                trb_comp_code)) {
@@ -1542,7 +1542,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        spin_unlock_irqrestore(&xhci->lock, flags);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1625,7 +1625,7 @@ struct xhci_hcd {
+@@ -1626,7 +1626,7 @@ struct xhci_hcd {
  #define XHCI_STATE_REMOVING   (1 << 2)
        /* Statistics */
        int                     error_bitmask;
@@ -1551,7 +1551,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  #define       XHCI_LINK_TRB_QUIRK     (1 << 0)
  #define XHCI_RESET_EP_QUIRK   (1 << 1)
  #define XHCI_NEC_HOST         (1 << 2)
-@@ -1661,6 +1661,9 @@ struct xhci_hcd {
+@@ -1662,6 +1662,9 @@ struct xhci_hcd {
  #define XHCI_SSIC_PORT_UNUSED (1 << 22)
  #define XHCI_NO_64BIT_SUPPORT (1 << 23)
  #define XHCI_MISSING_CAS      (1 << 24)