miniupnpc: update to 1.7
authorStephen Walker <stephendwalker@gmail.com>
Tue, 18 Dec 2012 03:36:00 +0000 (03:36 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Tue, 18 Dec 2012 03:36:00 +0000 (03:36 +0000)
SVN-Revision: 34745

net/miniupnpc/Makefile
net/miniupnpc/patches/100-no_minixml_test.patch
net/miniupnpc/patches/200-miniupnpc_desc.patch

index 1692d43f91158cae32bb62fa29614aa096fbdec4..1fef4e5be90c5c75b3ce462a0eee27c8f78d676f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpc
-PKG_VERSION:=1.6
+PKG_VERSION:=1.7
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=88055f2d4a061cfd4cfe25a9eae22f67
+PKG_MD5SUM:=297bee441b56af87c6622fc4002179fd
 
 PKG_INSTALL:=1
 
@@ -43,6 +43,7 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 MAKE_FLAGS += \
+       OS="Linux" \
        PREFIX="$(PKG_INSTALL_DIR)"
 
 define Build/InstallDev
index e549ef07175012a7d01561317eb36e9621595389..9aa5d4020f20a2978ae5842cebe647eb3de3bd5c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -107,8 +107,8 @@ installpythonmodule:       pythonmodule
+@@ -129,8 +129,8 @@ installpythonmodule:       pythonmodule
        python setup.py install
  
  validateminixml:      minixmlvalid
@@ -10,4 +10,4 @@
 +#     ./minixmlvalid
        touch $@
  
- clean:
+ validateminiwget:     testminiwget minihttptestserver testminiwget.sh
index 9a38847868de3a2936df2b4390d437c0755b1176..320707ef27618e839a327ff41929a6663a172297 100644 (file)
@@ -1,11 +1,11 @@
 --- a/upnpcommands.c
 +++ b/upnpcommands.c
-@@ -351,7 +351,7 @@ UPNP_AddPortMapping(const char * control
+@@ -367,7 +367,7 @@ UPNP_AddPortMapping(const char * control
        AddPortMappingArgs[5].elt = "NewEnabled";
        AddPortMappingArgs[5].val = "1";
        AddPortMappingArgs[6].elt = "NewPortMappingDescription";
 -      AddPortMappingArgs[6].val = desc?desc:"libminiupnpc";
 +      AddPortMappingArgs[6].val = desc?desc:"miniupnpc";
        AddPortMappingArgs[7].elt = "NewLeaseDuration";
-       AddPortMappingArgs[7].val = "0";
-       if(simpleUPnPcommand(-1, controlURL, servicetype, "AddPortMapping", AddPortMappingArgs, buffer, &bufsize) < 0) {
+       AddPortMappingArgs[7].val = leaseDuration?leaseDuration:"0";
+       if(!(buffer = simpleUPnPcommand(-1, controlURL, servicetype,