ramips: add support for Cudy X6
[openwrt/staging/chunkeey.git] / target / linux / ramips / image / mt7621.mk
index 5844682a4032a6e12c9b1e27bd17699b8255214b..cbdc63247d92f22c2132469edfbb9a31cc09dd6f 100644 (file)
@@ -318,6 +318,16 @@ define Device/cudy_wr2100
 endef
 TARGET_DEVICES += cudy_wr2100
 
+define Device/cudy_x6
+  $(Device/dsa-migration)
+  IMAGE_SIZE := 32256k
+  DEVICE_VENDOR := Cudy
+  DEVICE_MODEL := X6
+  UIMAGE_NAME := R13
+  DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += cudy_x6
+
 define Device/dlink_dir-8xx-a1
   $(Device/dsa-migration)
   IMAGE_SIZE := 16000k