lua: fix build with MacOS's make
[openwrt/staging/blogic.git] / package / utils / lua / patches-host / 001-include-version-number.patch
index b7056fd47c67f849c4ad72830d8a60d64e6072d7..f769e607367fb03660cf6353e6b2d050ea743b43 100644 (file)
@@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
  
  # Lua version and release.
  V= 5.1
+@@ -53,7 +53,7 @@ R= 5.1.5
+ all:  $(PLAT)
+ $(PLATS) clean:
+-      cd src && $(MAKE) $@
++      cd src && $(MAKE) $@ V=$V
+ test: dummy
+       src/lua test/hello.lua
 diff --git a/doc/lua.1 b/doc/lua5.1.1
 rename from doc/lua.1
 rename to doc/lua5.1.1