fix reserved area in firmware for 'dirty flag'
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 18:52:10 +0000 (18:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 18:52:10 +0000 (18:52 +0000)
SVN-Revision: 2249

openwrt/target/linux/image/brcm/Makefile

index 0740f6eb30945d97636875b2dee6bcd3fd5ad5b1..adebb5e8bdcff28c7f755f268b940dcd1ba346d9 100644 (file)
@@ -28,7 +28,7 @@ endif
 
 $(KDIR)/loader.tmp.gz:
        cp $(BUILD_DIR)/loader.gz $@
-       echo -e "\\x00" >> $@
+       echo -ne "\\x00" >> $@
 
 $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/loader.tmp.gz
        $(STAGING_DIR)/bin/trx -o $@ $(KDIR)/loader.tmp.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)