update dropbear to 0.49 for whiterussian as well
authorTim Yardley <lst@openwrt.org>
Sun, 8 Apr 2007 00:40:08 +0000 (00:40 +0000)
committerTim Yardley <lst@openwrt.org>
Sun, 8 Apr 2007 00:40:08 +0000 (00:40 +0000)
SVN-Revision: 6891

openwrt/package/dropbear/Makefile
openwrt/package/dropbear/patches/120-hostkey_prompt.patch

index 75eaf6e44c6bb2f39149254d014d5eb0139f7fca..8968e32db53990b4fe2bd394e20e1b9e81c88e5d 100644 (file)
@@ -3,11 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=0.48.1
+PKG_VERSION:=0.49
 PKG_RELEASE:=1
-PKG_MD5SUM:=ca8e53a766faec831882831364568421
+PKG_MD5SUM:=7b20c85f1ee34f018a1b948eae003df9
 
-PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
+PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
+                               http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
index 59639e7b979638073e1d3f4114e8e03321c28f15..d18bff86a2c862726073602a439bbb05ae4fe55f 100644 (file)
@@ -1,12 +1,11 @@
-diff -urN dropbear-0.45.old/cli-kex.c dropbear-0.45/cli-kex.c
---- dropbear-0.45.old/cli-kex.c        2005-03-07 05:27:01.000000000 +0100
-+++ dropbear-0.45/cli-kex.c    2005-03-25 11:13:57.000000000 +0100
-@@ -119,7 +119,7 @@
-       char response = 'z';
-       fp = sign_key_fingerprint(keyblob, keybloblen);
+--- dropbear-0.49/cli-kex.c.orig       2007-02-22 09:51:36.000000000 -0600
++++ dropbear-0.49/cli-kex.c    2007-03-22 13:45:57.000000000 -0500
+@@ -126,7 +126,7 @@
+               m_free(fp);
+               return;
+       }
 -      fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n", 
-+      fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n) ", 
++      fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)", 
                        cli_opts.remotehost, 
                        fp);
+       m_free(fp);