build: get rid of host.mk
[openwrt/staging/yousong.git] / target / linux / brcm2708 / image / Makefile
index 6916a2b4aed43a273142517bd93c178d970d4885..0b3f6a7588c1d3582acecf34f4e0bc7489c30ad0 100644 (file)
@@ -1,17 +1,20 @@
 # 
 # Copyright (C) 2012-2015 OpenWrt.org
-# Copyright (C) 2016 LEDE project
+# Copyright (C) 2016-2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
-include $(INCLUDE_DIR)/host.mk
 
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
+define Build/Compile
+       $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+endef
+
 ### Image scripts ###
 define Build/kernel-img
        perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
@@ -21,7 +24,7 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-       mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
+       mcopy -i $@.boot $(KDIR)/COPYING.linux ::
        mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
@@ -30,7 +33,7 @@ define Build/boot-img
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot config.txt ::
-       mcopy -i $@.boot $(word 1,$^) ::kernel.img
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
        $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
        mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
@@ -38,20 +41,18 @@ define Build/boot-img
 endef
 
 define Build/sdcard-img
-       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-       $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
 ### Devices ###
 define Device/Default
   FILESYSTEMS := ext4
   KERNEL := kernel-bin | kernel-img
+  KERNEL_IMG := kernel.img
   IMAGES := sdcard.img
   IMAGE/sdcard.img := boot-img | sdcard-img
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_DTS
 
 define Device/rpi
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
@@ -62,17 +63,19 @@ ifeq ($(SUBTARGET),bcm2708)
 endif
 
 define Device/rpi-2
-  DEVICE_TITLE := Raspberry Pi 2 B
-  DEVICE_DTS := bcm2709-rpi-2-b
+  DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
+  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
 endef
 ifeq ($(SUBTARGET),bcm2709)
   TARGET_DEVICES += rpi-2
 endif
 
 define Device/rpi-3
-  DEVICE_TITLE := Raspberry Pi 3 B
-  DEVICE_DTS := bcm2710-rpi-3-b
-  DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+  KERNEL_IMG := kernel8.img
+  DEVICE_TITLE := Raspberry Pi 3B (64 bit)
+  DEVICE_DTS := broadcom/bcm2710-rpi-3-b
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
 endef
 ifeq ($(SUBTARGET),bcm2710)
   TARGET_DEVICES += rpi-3