opkg: add update-alternatives support
[openwrt/staging/yousong.git] / package / system / opkg / Makefile
index fbf87cb34ff74506562ad8df159ce919c046bcf6..56f5cce2baf4c09fabdeae4e062c007cec53649a 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=opkg
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
@@ -94,6 +94,9 @@ define Package/opkg/install
   endif
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/update-alternatives $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       touch $(1)/etc/config/opkg
 endef
 
 define Host/Install