add x86_64 target support
[openwrt/staging/yousong.git] / package / boot / grub2 / Makefile
index dd490ff17182a3bdefd449af89a7264566d3f3cb..20dced94801b9c9f78530f3012922f5d7fae1a2a 100644 (file)
@@ -28,7 +28,7 @@ define Package/grub2
   SECTION:=utils
   TITLE:=GRand Unified Bootloader
   URL:=http://www.gnu.org/software/grub/
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86||TARGET_x86_64
 endef
 
 define Package/grub2-editenv
@@ -36,7 +36,7 @@ define Package/grub2-editenv
   SECTION:=utils
   TITLE:=Grub2 Environment editor
   URL:=http://www.gnu.org/software/grub/
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86||TARGET_x86_64
 endef
 
 define Package/grub2-editenv/description