at91: separate MKUBIFS opts to defaults in the sub target
[openwrt/staging/stintel.git] / target / linux / at91 / image / Makefile
index c0239ea050c64f0986c9daf4ed5f702c2befd734..db480ac754506cbaed6be4cf628a7757b6c800f1 100644 (file)
@@ -1,45 +1,68 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
-       $(MAKE) -C dfboot clean
-       $(MAKE) -C u-boot clean
+KERNEL_LOADADDR := 0x20008000
+
+ifeq ($(SUBTARGET),legacy)
+include ./legacy.mk
+endif
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
+endif
+
+define Device/Default
+  $(Device/default-nand)
+  PROFILES := Default
+  FILESYSTEMS := squashfs ubifs
+  DEVICE_DTS := $(1)
+  KERNEL_NAME := zImage
+  KERNEL_SIZE := 4096k
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+  DTB_SIZE :=
+endef
+
+define Device/dtb
+  KERNEL := kernel-bin | lzma | uImage lzma
+endef
+
+define Device/evaluation
+  KERNEL_INSTALL := 1
+  KERNEL_SUFFIX := -uImage
+  IMAGES := root.ubi
+  IMAGE/root.ubi := append-ubi
 endef
 
-define Build/Compile
-       $(MAKE) -C dfboot compile
-       $(MAKE) -C u-boot compile
-       $(KDIR)/u-boot-1.1.4/tools/ubparams
-       cp params $(KDIR)
+define Device/evaluation-zImage
+  IMAGES += zImage
+  IMAGE/zImage := install-zImage
 endef
 
-define Image/Prepare
-  cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-       cp $(KDIR)/dfboot/dfboot.bin $(KDIR)/dfboot.bin
-       cp $(KDIR)/dfboot/dfbptest.bin $(KDIR)/dfbptest.bin
-       cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
-       dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
-       cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
+define Device/evaluation-dtb
+  $(Device/evaluation)
+  $(Device/dtb)
+  $(Device/evaluation-zImage)
+  IMAGES += dtb
+  IMAGE/dtb := install-dtb
 endef
 
-define Image/BuildKernel
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+define Device/production
+  UBINIZE_OPTS := -E 5
+  IMAGES := factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
 
-define Image/Build
-       dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
-       dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
-       cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
-       $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
-       cp $(KDIR)/dfbptest.bin $(BIN_DIR)
-       $(call Image/Build/$(1),$(1))
+define Device/production-dtb
+  $(Device/production)
+  $(Device/dtb)
+  DTB_SIZE := 128k
+  IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
+         | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
 
 $(eval $(call BuildImage))