armsr: armv8: enable serial console for Renesas platforms
[openwrt/staging/stintel.git] / include / uclibc++.mk
index 817484377fcee9c0f55f5238e57a4e62bc791848..10f8d98e15132314c9dac04fa8e4d498389c3a26 100644 (file)
@@ -1,12 +1,2 @@
-ifndef DUMP
-  ifdef __package_mk
-    $(error uclibc++.mk must be included before package.mk)
-  endif
-endif
-
-PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
-CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
-
-ifneq ($(CONFIG_USE_UCLIBCXX),)
-  TARGET_CXX="g++-uc"
-endif
+$(warn uclibc++.mk is deprecated. Please remove it and CXX_DEPENDS)
+CXX_DEPENDS = +libstdcpp