kernel: bump 5.15 to 5.15.140
[openwrt/staging/stintel.git] / include / target.mk
index a62b1eb0527aab6ec89a356733b7a456411073fa..b5e3e7ff6fdeca22c917c7024d53914d32d82a7e 100644 (file)
@@ -17,7 +17,7 @@ DEFAULT_PACKAGES:=\
        fstools \
        libc \
        libgcc \
-       libustream-wolfssl \
+       libustream-mbedtls \
        logd \
        mtd \
        netifd \
@@ -260,6 +260,10 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_arc700 = -mcpu=arc700
     CPU_CFLAGS_archs = -mcpu=archs
   endif
+  ifeq ($(ARCH),riscv64)
+    CPU_TYPE ?= riscv64
+    CPU_CFLAGS_riscv64:=-mabi=lp64d -march=rv64imafdc
+  endif
   ifneq ($(CPU_TYPE),)
     ifndef CPU_CFLAGS_$(CPU_TYPE)
       $(warning CPU_TYPE "$(CPU_TYPE)" doesn't correspond to a known type)